Error "Failed to authorize the server certificate" with NX version 6.6.8 webplayer

Forums / NoMachine Terminal Server Products / Error "Failed to authorize the server certificate" with NX version 6.6.8 webplayer

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #22121
    Avatarmelih.kinci
    Participant

    Dear All,

    I did some research and couldn’t find the solution, i believe i can find it. I’m trying to activate NX webplayer but faced an error message as below.

    I appreciate any kind of help. I removed the ssl certificate from the htd.cfg and changed the link asĀ http://xx.xx.xx.xx:4080/nxwebplayer (IP removed)

    Info: Handler started with pid 28805 on Wed Apr 24 08:30:21 2019.

    Info: Handling connection from xx.xx.xx.xx port 42200 on Wed Apr 24 08:30:21 2019.

    28795 28804 08:30:21 776.704 Encryptor/Encryptable: ERROR! Failed to authorize the server certificate.

    Error: Failed to authorize the server certificate.

    28795 28804 08:30:21 776.858 Channel/Channel: WARNING! Runable DaemonReader failed for FD#12.

    28795 28804 08:30:21 776.872 Channel/Channel: WARNING! Error is 13, ‘Permission denied’.

    28795 28798 08:30:21 777.688 DaemonClientApplication/DaemonClientApplication: WARNING! Session terminated abnormally.

    28795 28798 08:30:21 777.717 DaemonClientApplication/DaemonClientApplication: WARNING! Error is 13, ‘Permission denied’.

    _NXThreadWrite: ERROR! No signaling channel found.

    28795 28795 08:30:21 810.499 DaemonClientApplication/DaemonClientApplication: WARNING! No client running in 0x3074340.

    Info: Connection from xx.xx.xx.xx port 42200 closed on Wed Apr 24 08:30:21 2019.

    Info: Handler with pid 28805 terminated on Wed Apr 24 08:30:21 2019.

    Info: Handler started with pid 28863 on Wed Apr 24 08:30:25 2019.

    Info: Handling connection from xx.xx.xx.xx port 42208 on Wed Apr 24 08:30:25 2019.

    28852 28862 08:30:25 298.598 Encryptor/Encryptable: ERROR! Failed to authorize the server certificate.

    Error: Failed to authorize the server certificate.

    28852 28862 08:30:25 298.725 Channel/Channel: WARNING! Runnable DaemonReader failed for FD#12.

    28852 28862 08:30:25 298.738 Channel/Channel: WARNING! Error is 13, ‘Permission denied’.

    28852 28856 08:30:25 298.979 DaemonClientApplication/DaemonClientApplication: WARNING! Session terminated abnormally.

    28852 28856 08:30:25 299.032 DaemonClientApplication/DaemonClientApplication: WARNING! Error is 13, ‘Permission denied’.

    _NXThreadWrite: ERROR! No signaling channel found.

    28852 28852 08:30:25 327.374 DaemonClientApplication/DaemonClientApplication: WARNING! No client running in 0x2c65310.

    Info: Connection from xx.xx.xx.xx port 42208 closed on Wed Apr 24 08:30:25 2019.

    Info: Handler with pid 28863 terminated on Wed Apr 24 08:30:25 2019.

     

    #22220
    Avatarirek
    Participant

    Hello,

    can you please describe what are you trying to do by removing ssl certificates,
    is it because you want to have only HTTP or both HTTP and HTTPs instead of only having HTTPs?

    Can you also send to us htd.cfg and server.cfg configuration files.

    Please send all the info to forum[at]nomachine[dot]com making sure to reference the topic.

    #22253
    Avatarmelih.kinci
    Participant

    hello,

    i have sent it. I would like to use webplayer but it does not work. (error message: the connection with the server was shutdown)

    Best Regards,

    #22254
    Avatarmelih.kinci
    Participant

    Hi,

    I’m trying to use webplayer but when i try, it throws an error that the connection with the server was shut down.

    Regards,

    #22262
    Avatarirek
    Participant

    Hello,

    we would need some more information

    1 Could you please send to use all configuration files *.cfg from :

    # /usr/NX/etc/

    If you don’t show us the htd.cfg, it’s hard for us to advise appropriately.

    2 Please execute this command in terminal:

    # /etc/NX/nxserver --version

    3 From server.cfg I can tell 2 things

    3.1 HTTP is disabled

    #
    # Specify how clients will have to contact the node, by default by
    # the NX service. To allow for multiple methods, specify them in a
    # comma-separated list. Supported methods are: NX, SSH and HTTP.
    #
    ClientConnectionMethods NX,SSH

    to enable you have to add HTTP:

    ClientConnectionMethods NX,SSH,HTTP

    Restart of nxserver is required.

    3.2 it looks like this is old version maybe v5, if thats true is this possible to update to latest v6?

    4 We would ned alos to see all logs.
    Instructions about debug and collecting logs you can find there: https://www.nomachine.com/AR07K00677

    Please send them to forum[at]nomachine[dot]com making sure to reference the topic.

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.