"Failed to connect the printer" on Windows Client

Forums / NoMachine Terminal Server Products / "Failed to connect the printer" on Windows Client

Tagged: 

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #6277
    Avatarmemanuele
    Participant

    I have installed NoMachine Terminal Server for Linux on a Debian 7 machine. Everything seems to be working fine except for the printing. At first the “share local printer” option was grayed out on the client. After installings CUPS the option become enabled and I was able to share the printers with the root account. After this, I created some other users with nxserver –useradd and these users are unable to share printers. The client shows this error:

    Failed to connect the printer …

    I was wondering what could be the cause of the issue. Thanks.

    Attachments:
    #6290
    Avataradamski
    Participant

    Hi.
    To connect a printer, user must be added to “lpadmin” group.
    Please check if user is added to this group.
    To check it please log into this user: su <username>, then type “groups”.
    You can also check it in group file: /etc/group.
    To add user to “lpadmin” group just execute folowing command: sudo usermod -a -G lpadmin <username>

    If this doesn’t help, please give us more information.

    1. Client and server NoMachine subscription and version

    2. Client and server operating systems.

    3. Where the printer is connected to? (Client, Server)

    4. The printers is attached by usb or lan?

    5. Please describe the route connecting the printer.
    (You are trying connect printer TO Debian 7 from other PC, or share printer attached to this Debian?)

    #6286
    Avatarmemanuele
    Participant

    Seems like I solved the problem by adding the users to the lpadmin group.

    Is the CUPS server a requirement for local printing to work?

    Thanks.

    #6296
    Avataradamski
    Participant

    We are glad that we could help solve this problem. CUPS must be installed to get printing to work.

     

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.