Failed to map the port on D-link

Forums / NoMachine for Windows / Failed to map the port on D-link

This topic contains 10 replies, has 2 voices, and was last updated by Avatar Britgirl 5 days, 14 hours ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #24336
    Avatar
    aacm
    Participant

    Hello everyone.. I am new here and try to connect my computer to NoMachine thru D-Link router  DIR-890L, however I not available to get the IP address  NX so I try to check mark the Gateway port and got error “Failed to map the port on the gateway”, because I believe I need this in order to get the IP address that need it for connection thru internet from other location…

    So I want to know what is the steps necessaries to avoid this error..

    Thanks in advance and I appreciated all your help..

    AACM

    #24362
    Avatar
    Britgirl
    Keymaster

    Have a look here at Kroy’s suggestion in: https://forums.nomachine.com/topic/server-with-vpn

    If you are changing the gateway port via nxclient GUI it might be the problem https://www.nomachine.com/TR12N07384.

    This also could be helpful:
    https://forums.nomachine.com/topic/redirecting-port#post-18249

    #24366
    Avatar
    aacm
    Participant

    OK thanks Britgirl . I will check thanks

    #24385
    Avatar
    aacm
    Participant

    Well not success yet.. I notice the problem probably comes from my wireless router.. the UPNP is active …  but I don’t know what I can not get public address in the welcome page??   I try those suggestions and I appreciated so much and still not working..huhh, I think is something with my router, because yesterday I installed in my friend house and works right away, of course he doesn’t have my type of router. SO I wait any other suggestions.  Again I appreciated

    #24387
    Avatar
    Britgirl
    Keymaster

    I try those suggestions

    The instructions about port-forwarding here? https://www.nomachine.com/AR11L00827

    Can you describe more about your environment? Where are you connecting from? Where is the computer that you want to connect to? If you have enabled UPnP, it should show External IP and Port.

    Can you paste here output (from within a terminal):

    "c:\Program Files (x86)\NoMachine\bin\nxserver" --upnpstatus
    "c:\Program Files (x86)\NoMachine\bin\nxserver" --upnpmap
    

    Can you answer these questions?

    – does your computer have a permanent IP ?

    – is port 4000 on the router redirected to the IP address of the your computer?

    – does your home IP address change often ? Can you check what your public-facing IP address is? (https://forums.nomachine.com/topic/public-ip)

    For your router try the instructions to enable port-forwarding correctly: https://www.dlink.com.sg/how-do-i-open-ports-on-my-dir-890l/. Does this help?

    #24388
    Avatar
    aacm
    Participant

    Thanks again Britgirl.. I will applied all your suggestions

    I will post the results.

    I will also post your questions, when I get to my place

    Thanks again

    #24391
    Avatar
    aacm
    Participant

    Here is the nxserver from C:\program Files (x86)

    Thanks for  the link of my router I changed because open port wrong.. I corrected. and No my PC doesn’t have permanent IP, and the public IP address is not appear in the welcome windows only my home ip address.  Thats is the problem that I can not connect to my PC from other place because the public IP not appear in there , only my local IP.

    And my Home IP doesnt change often.  I know what is my public IP address.  So I thought the network services the Gateway port has uncheck mark, meaning that is the problem OK so I check the Gateway port there BUT give me a error said: “Failed to map the port on the gateway” that’s why I believe is a problem with this because not show public IP address, so I can not connect outside of my home.

    Hope I made myself clear of the problem I can give you picture of it, if you want.  Appreciated again your help.

     

    #24397
    Avatar
    Britgirl
    Keymaster

    You didn’t paste output of the commands 🙂 Are you sure that EnableUPnP key has ‘NX’ set as its value?
    Anyway, you still can use port forwarding. Perhaps these instructions are clearer: https://portforward.com/d-link/dir-890l/ You can see in the last picture there is TCP Port and UDP Port. You should set these to 4000. Then you need to set your static IP (again as shown in the how-to). Please also make sure you reserve IP address for your host or set the static IP.

    The upcoming release of NoMachine Network will mean that port-forwarding won’t be necessary, and you won’t need to know your IP address. Watch out for that. You can follow the Feature Request here: https://www.nomachine.com/FR07J02731.

     

    #24406
    Avatar
    aacm
    Participant

    Again thank you for your time  is appreciated…

    I sent you the nxserver please let me know IF you received.  Awesome for the upcoming updated.  OK so I need to setup static IP.. ok will do it..

    #24408
    Avatar
    Britgirl
    Keymaster

    Send any attachments to forum[at]nomachine[dot]com directly, make sure you put the title of the topic as the subject.

    Thanks.

    #24439
    Avatar
    Britgirl
    Keymaster

    We can see from the server.cfg file you sent in privately hat UPnP is enabled. We see NXUPnPPort 27468. Maybe this port is blocked by firewall or is being used by another application maybe?

    Can you find the line: NXUPnPPort 27468 in the server.cfg and comment it out by adding # on the beginning? Then do from a terminal:

    "c:\Program Files (x86)\NoMachine\bin\nxserver" --restart
    "c:\Program Files (x86)\NoMachine\bin\nxserver" --upnpmap

    The output should look like this:

    Local IP 10.0.1.2
    Gateway IP 10.0.1.1
    External IP 11.222.333.444
    NX port 4000 mapped to: 11.222.333.444:23484
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.