Fedora 22 problem. Walland related ?

Forums / NoMachine for Linux / Fedora 22 problem. Walland related ?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7662
    baj
    Participant

    Hi,

    Since I’ve upgraded my Fedora boxes from FC21 to FC22, I have serious problems to connect a NX 4 client (Linux or Mac) to the physical display of my server(s). All the computers have the latest NoMachine 4.6.4, free version.

    By default, FC22 doesn’t use X11 for GDM, but uses Wayland instead. NoMachine doesn’t seem to be able to display the Wayland GDM login screen. If I log in from the server, the NoMachine client is able to display the (Gnome 3) physical desktop (but it resizes the display even if I ask in the client not to do that). This means that I can’t connect to a remote physical session that is not logged on.

    If I force GDM to use X11 (in /etc/gdm/custom.conf) , the GDM login screen can be displayed in the NoMachine client. But once logged in from the client, a black screen is displayed instead of the (Gnome 3) desktop, which is correctly displayed on the server. It seems that the connection is somewhere lost (I can’t see the connected client in the NoMachine server GUI. I’ve tested other desktops, such as Mate, with ┬áno more success.

    Any idea ?

    #7699
    Britgirl
    Keymaster

    We haven’t been able to reproduce the problem. Can you send us logs? Instructions are here:

    https://www.nomachine.com/AR07K00677

     

    Please send them to forum[at]nomachine[dot]com.

    #7785
    graywolf
    Moderator

    baj, I read the logs and problem seems due to incompatibility with GDM provided by Fedora 22. I’m going to try different display managers and let you know.

    #7787
    graywolf
    Moderator

    Switching display manager to LightDM is an effective workaround.

    Install lightdm:
    [root@test01 ~]# dnf install lightdm

    Disable GDM:
    [root@test01 ~]# systemctl disable gdm

    Enable LightDM:
    [root@test01 ~]# systemctl enable lightdm

    Reboot to make changes effective:
    [root@test01 ~]# reboot

    #7794
    baj
    Participant

    Thank you Graywolf,

    This seems to work indeed.

    The only small problem with lightDM is that the NX client keyboard seems always to act in QWERTY mode, even if another language is selected in the display manager UI. The problem does not occur on the physical (server side) keyboard.

    However, once in Gnome, my client side keyboard correctly works in AZERTY (Belgian), so that I can work normally.

    Thanks again.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.