Fedora 36 headless server

Forums / NoMachine for Linux / Fedora 36 headless server

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40077
    MastaG
    Participant

    Hi there,

    I’m trying to setup NoMachine on my Fedora 36 headless server (which runs on a VM).
    So I’m unable to physically access it.

    I first installed the Gnome desktop and Fedora Workstation groups using DNF.
    Then I proceed to install nomachine-7.10.1-1.x86_64 from RPM.

    Because the VM is headless, I’m running the multi-user.target.
    So the GDM display-manager is not active.

    The following ports are opened in the firewall: 4000/tcp 4011-4999/tcp 5353/udp

    When I try to connect, it prompts me to create a new display, but when I proceed the connection closes.
    nxserver.log:
    3180 3180 2022-09-09 12:38:33 504.115 NXSERVER Starting LS 7.10.1 and services.
    3180 3180 2022-09-09 12:38:33 504.230 NXSERVER System information: Fedora, standalone.
    3226 3226 2022-09-09 12:38:58 926.749 NXSERVER User 'mastag' logged in from '85.145.198.224' using authentication method NX-password.
    3260 3260 2022-09-09 12:39:07 892.272 NXSERVER WARNING! Cannot retrieve node socket for session 6FDD6C03D87C94FB658309C1AF885485.
    3226 3226 2022-09-09 12:39:11 617.846 NXSERVER User 'mastag' from '85.145.198.224' logged out.

    I’ve tried different commands for the default desktop:
    DefaultDesktopCommand "/etc/X11/Xsession default"
    DefaultDesktopCommand "env GNOME_SHELL_SESSION_MODE=classic gnome-session –session gnome-classic"

    But it doesn’t seem to make a difference.

    Any ideas?

    #40084
    katpan
    Participant

    Hi MastaG,

    Thank you for the information you provided us with.

    Our team will investigating the issue asap.

    Please send logs as attachments to forum[at]nomachine[dot]com making sure to use the title of the topic as the subject of your email. Thanks!

    #40085
    MastaG
    Participant

    Thank you katpan,

    I’ve emailed over the logs.
    Please let me know if I can provide further information.

    #40111
    Bilbotine
    Keymaster

    Hello MastaG,

    Thank you for the logs; having reviewed them, we would like you to:

    enable the logs in node configuration file (node.cfg),

    restart the nxserver,

    reproduce the problem,

    and then share .nx from home dir of user on server side.

    using nxserver –debug enable, nxserver –debug –collect should help to create the package with logs.

    As previously, please send us the logs by email.

    Thank you!

    #40130
    MastaG
    Participant

    Hi Bilbotine,

    I’ve just sent over an updated logs.tar.gz archive.
    It contains the .nx directory and the .zip archive created with the “–debug –collect” command.

    I hope it helps.

    #40138
    Bilbotine
    Keymaster

    Hi MastaG,

    Thank you for the logs, we’ll have a look and come back to you soon.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.