Fedora Linux firewall commands to enable NoMachine version 4.x

Forums / NoMachine for Linux / Fedora Linux firewall commands to enable NoMachine version 4.x

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #3420
    dcmores
    Participant

    After I updated my installations of NoMachine NX V3.x to NoMachine V4.0 (free version), I found that I could no longer make any successful connections (server timeout errors) from my Windows 7 machine to my Fedora 20 machine.  Consulting the NoMachine site’s support and documentation section, a paper advised me that the problem was likely a network issue with the firewall on the machine being contacted.  After I shutoff its firewall, connections started working.

    <b># systemctl status firewalld.service</b>
    <b># systemctl stop firewalld.service

    <test starting a connection>
    </b>
    <b># systemctl start firewalld.service</b>

    Configuration changes with the firewall would be needed to keep it running.  Since the free version of NoMachine V4.0 only supports working with the <b><i>nx</i></b> protocol type and ports 4000 and 4309, the following commands on my Fedora system made my use of NoMachine V4.0 functional:

    <b># firewall-cmd  –add-port=4000/tcp</b><b>
    </b><b># firewall-cmd  –permanent –add-port=4000/tcp</b><b>
    </b><b>
    </b><b># firewall-cmd  –add-port=4309/udp</b><b>
    </b><b># firewall-cmd  –permanent –add-port=4309/udp</b>

    The above commands are applied to the default firewall zone<b> </b><b><i>public</i></b>.

    If you are interested in what zones there are, this command list all the known firewall zones.

    <b># firewall-cmd –list-all-zones</b>

    If you want to check your <b><i>public</i></b> zone after the above ports are added for NoMachine V4.0, use this command:

    <b># firewall-cmd –zone=public –list-all</b>

    public (default, active)
    interfaces: ra0
    sources:
    services: dhcpv6-client ipp ipp-client mdns ssh
    ports: 4000/tcp 4309/udp
    masquerade: no
    forward-ports:
    icmp-blocks:
    rich rules:
    #

    My experience with firewall is limited.  So there may be other configurations to get NoMachine working with it.  Firewall has extensive configurations options available.

    #3489
    adp
    Participant

    Firewall rules in Fedora were added to NoMachine 4.2.15, so if you are not using the latest version (you say you are using 4.0) then this could be the reason for why it’s not working.

    We have not been able to reproduce. If you -are- using the latest version, please send us output of the following command (ran as root):

    iptables -L INPUT -n –line-numbers

    It would be helpful to have the output before and after NoMachine installation, but the latter is more important.

Viewing 2 posts - 1 through 2 (of 2 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.