Fix for large cursor when grabbing mouse input?

Forums / NoMachine for Mac / Fix for large cursor when grabbing mouse input?

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #36132
    gabeg3377
    Participant

    I was having a problem with a large cursor when remoting into a Windows 10 desktop from a MacBook Air with an M1 processor and macOS 11. Increasing the scaling on the just made the large cursor even larger and more common. For anyone else with the problem, having NoMachine not grab the mouse input seems to have fixed the problem. It also reduces how often touchpad motion accidentally brings up the Mac’s sidebar. I’m running version 7.6.4, the free version.

    The MacBook is using the internal display while I’m remoting into a virtual display.

    #36177
    fra81
    Moderator

    It’s a bit strange that disabling the pointer grab can have an effect on this issue. Would you double check?

    Please also try to check the ‘Show remote cursor pointer’ option. Now you should see two cursors in the session, the local one and the remote one. Do they both look large or just one of them? Which one?

    #36181
    gabeg3377
    Participant

    I have been using it more heavily since turning off the pointer grab, so I have triple checked. I turned mouse grab back on and the cursor immediately slowed down and became big on some motions, mostly rapid ones, but sometimes slow ones. Turning it back off makes the cursor move smoothly and consistently again. When small, the cursor is completely white. When big, it has a black interior.

    Having ‘show remote cursor’ and ‘mouse grab’ both on has one big cursor, apparently the local one, and one small one, the remote one, which never enlarges. It seems to happen when the remote cursor falls behind the local cursor. With ‘mouse grab’ turned off, when the local and remote cursors separate, the local cursor remains small, unlike with ‘mouse grab’ on.

    #36182
    gabeg3377
    Participant

    Just to clarify, with ‘show remote cursor’ and ‘mouse grab’ both on, I get one big cursor and one small cursor. With ‘show remote cursor’ on and ‘mouse grab’ off, I get two small cursors, never enlarging. With ‘show remote cursor’ off and ‘mouse grab’ on, I get one large cursor. With both options off, I get one small cursor.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.