Forwarding USB from local Windows to MacOS

Forums / NoMachine for Windows / Forwarding USB from local Windows to MacOS

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #26027
    AvatarluckyBadger
    Participant

    I’m trying to connect a local USB stick to remote macOS Catalina 10.15.

    Whenever I try to connect via NoMachine, the USB drive gets disconnected for a few second, my remote macOS displays a DaemonLoadDriversFailed_Text popup, USB gets reconnected, and NoMachine tells me that it failed to connect the device.

    I’ve tried connecting iPad and a USB drive, both result in the same error, so I suppose there’s a problem with the whole forwarding module. I also tried running NoMachine with admin rights on Windows, but it didn’t help.

    What should I do?

    #26116
    AvatarTheEvilJester
    Participant

    Hello,

    I have a very similar problem – Windows 10 1903 client, mac osx mojave 10.14.6 server (remote), NoMachine 6.9.2.

    I tried connecting both an usb stick and an iPhone with iOS 12.1.4 (already trusted by windows) – in both cases the device disappears from windows for several seconds (20-30), then appears back.

    Unlike luckyBadger though I don’t get any popups on the remote mac – only a mention in the menus that it “failed to connect the device” like in his screenshot.

    Any ideas?

    Thank a lot!

    #26129
    AvatarGiorgi-G.
    Contributor

    Hi,

    The actual continuing of this post was in this thread https://forums.nomachine.com/topic/forwarding-ipad-connected-to-local-windows-to-macos-server

    In your case, you can try a few things.

    1. If possible connect from your Win client to any other remote machine to be sure that it’s not Windows related issue.

    2. Check, do you see on NM Menu -> Devices -> Connect a USB device, USB devices from both machines?

    3. To be sure that USB forwarding module works well on the remote (Mac) side please connect to Mac via NM, open NM Menu -> Devices -> Connect a USB device, after USB devices from both machines will appear, close NM menu (but not session) and open Terminal on Mac, run this command kextstat | grep com.nomachine and send output here.

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.