Fresh install cannot password authenticate

Forums / NoMachine for Linux / Fresh install cannot password authenticate

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #3620
    Avatartgt1
    Participant

    I can password authenticate from RHEL 6.5 to Windows 7 just fine.  Also, Windows7 to Windows7 works great.  However, I get authentication failed when trying to password authenticate from Windows7 or RHEL6.5 to RHEL6.5.  I can ssh from another linux machine’s terminal and log into the linux host machine just fine, so SSH from a remote machine works and so does my username/password.

    These are physical machines, free version 4 of NoMachine, Gnome

    I’m behind a secure wall and unfortunately cannot provide logs, but will be looking at them tomorrow. Can you point me to or provide a list of some “simple” things to check?

    I’ve been reading other threads and seen the following things to maybe check:

    1.  Check to ensure you can SSH from localhost on the machine you are trying to authenticate to.

    2.  Check to ensure permissions are set a certain way on certain folders/files.

    3.  Ensure password authentication is enabled in sshd_config

    4.  hosts.allow should have sshd:LOCAL and/or 127.0.0.1

    5.  Permissions???   sudo chmod 644 /etc/NX/server/localhost/*

    6.  Some mentions of disabling SELinux

    FYI, my linux experience is comically shallow.  Thanks for any help.  I know the details are lacking in my post, but my setup is very “standard” and there must be a small set of things to check that might not be quite correct for password authentication from windows7/linux to RHEL6.5…I hope.

    #3644
    Avataradp
    Participant

    Hello,

    could you please specify which protocol you use when you try to connect to the problematic server? Is it NX or SSH? In any case, please send us /usr/NX/var/log/nxerror.log from the server and compressed $HOME/.nx from client, after reproducing the issue. Before you try to reproduce the problem please make sure that client will not remove logs after you close it. To do so open the Player and go to Preferences -> Appearance and check “Don’t delete old log files on exit”.

    Thank you.

    #3698
    Avataraws1
    Participant

    I work with user tgt1. We are using the NX protocol for NoMachine (the free version). We are on secure systems and cannot send/upload logs, but the nxerror.log file shows:
    nxexecPAMCheckCredentials: Authentication failed with error 6.

    The nxserver.log file shows:
    2014-05-20 16:18:43 287.387 4708 NXSERVER ERROR: Process with pid 4745 terminated because of signal 1.
    2014-05-20 16:18:43 287.527 4708 NXSERVER ERROR: Error while trying to authenticate user: xxxxxx
    NXNssUserManager::auth returned 1
    2014-05-20 16:18:43 287.655 4708 NXSERVER ERROR: wrong ‘nxexec authentication’ for user ‘xxxxxx’ from ‘[IP of remote machine]’.

    #3724
    Avataradp
    Participant

    Hello,

    If you cannot send whole log files, could you please, after reproducing the issue, send us of the following command (ran as root):

    grep -R nxexec /var/log/*

    Knowing your PAM configuration would  be also very helpful, so if you could share the contents of:

    /etc/pam.d/nx

    /etc/pam.d/su

    /etc/pam.d/system-auth

    we would be grateful.

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.