Fresh install of Ubuntu desktop 22.04 LTS : No sound

Forums / NoMachine for Linux / Fresh install of Ubuntu desktop 22.04 LTS : No sound

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #41546
    noRob
    Participant

    Did a fresh new Ubuntu install on my laptop. Everything was working before the install btw.

    Running NoMachine server version 8.2.3

    I do not have sound on the client. Client runs on Windows 11.

    Also, I checked ‘Mute sound on server’, but the sound still plays on the server.

    Any ideas ?

    #41583
    kroy
    Contributor

    What audio tool is set on node configuration? To check this please show output of the command:

    sudo grep AudioInterface /usr/NX/etc/node.cfg

    Default on Ubuntu 22.04 should be set:

    AudioInterface pulseaudio

    If you have different, please open /usr/NX/etc/node.cfg file and set mention value.

     

    #41599
    noRob
    Participant

    Thanks Kroy, that was it.

    I changed the setting (and the startup command in the same file), and then I got it to work.

    It was a little odd, as I could not stop it from playing sound both on the client and on the server, even though I had ‘mute server’ checked.

    But by blocking the server speakers via pulse volume control it’s now only playing on the client.

    Thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.