Function keys aren’t sent from Windows client to Mac server

Forums / NoMachine for Windows / Function keys aren’t sent from Windows client to Mac server

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #34511
    Avatarblandy
    Participant

    I have a 2014 Macbook pro running Big Sur. I’m running the latest NoMachine software on it. I’m running a NoMachine client on my Windows 7 desktop, and connecting from the Windows machine to the Mac. I’m using an Apple keyboard to drive my Windows desktop. I have “Grab the mouse input” and “Grab the keyboard input” checked. I’m running the Windows server in fullscreen mode.

    Keystrokes like command-c/command-v work fine from the Windows client. However I’m unable to use the function keys on my keyboard to control the behavior of the Mac server. For example, pressing F10/F11 on the keyboard should trigger volume up/down. F1/F2 should change the display brightness. They seem to have no effect, including if I hold down the fn key on my keyboard on the Windows client.

    I’ve discovered if I press F7 on the Windows client, it triggers Chrome’s F7 handling shortcut in the Mac server. So it’s sending something to the Mac, just not what I would expect. Because this is a combination of a Windows client, an Apple keyboard, and a Mac server, I’m not sure what to debug in the chain.

    Based on other threads, I did try adding

    DisplayServerExtraOptions “-oldeventapi 0”

    to

    /Applications/NoMachine.app/Contents/Frameworks/etc/node.cfg

    on my Mac server, and restarted the server, then reconnected. It seemed to have no effect.

    The functionality works as expected if I plug the same keyboard directly into the Mac and don’t use NoMachine.

    I don’t know if this is related, there are two other behaviors that aren’t working:

    1. The keyboard combo control-command-left isn’t getting sent properly from Windows server to Mac client. It’s supposed to trigger a shortcut I have set up which works if I do it directly on the Mac’s keyboard.

    2. My mouse has back/forward buttons on it. Those aren’t triggering back/forward from Windows client to Mac client either. I see [this thread](https://forums.nomachine.com/topic/logitech-mouse-extra-buttons-arent-passed-to-ubuntu) but no resolution.

    #34518
    Avatarblandy
    Participant

    Latest updates / issues:

    1. Function keys aren’t being sent as media keys, and it’s not related to Windows nor the physical keyboard. I can reproduce function keys not being sent properly as media keys from one Macbook nomachine’d into another Macbook. I’m currently working around this issue by setting up new mappings for shortcuts using standard Apple shortcuts. For example I remapped “show desktop” (normally a function key) to command-shift-d, which works through NoMachine.
    2. I’m able to use the shortcut control-option-left/right (which I use to resize windows), to one Macbook (2018), but not to another Macbook (2014). I’m not sure what the difference is. They’re both running with “oldeventapi” on the server.
    3. My mouse back/forward buttons still aren’t forwarded
    4. I have a 4k monitor, and the resolution is blurry from both Macbooks. I think this a known issue about high DPI monitors.
    5. The shortcut Command-L, which focuses the URL bar in Chrome on Mac, is instead captured by my Windows host, which logs me out every time I try to focus the URL bar. I’m on Windows 7. When it logs me out, the command/windows key is then stuck down, so I have to log back in and tap the windows key. Frustrating since it’s a shortcut I use a LOT. I’ve remapped it to command-shift-L, which isn’t captured by Windows, on my Macbook and I’m trying to re-learn the muscle memory.
    6. On Windows 7, even in fullscreen, the windows task bar still shows up over the NoMachine window. I’m not sure if this is a Windows 7 specific issue, or something wrong with my Windows 7 setup, or something else. Since I keep both Windows bar and Mac dock on the bottom of the screen, they conflict. I’m working around this by moving the Windows taskbar to a different place, but no matter where I put it, it overlaps something in the NoMachine client. I don’t have this issue with full screen games. I’ve set the windows taskbar to auto-hide, but it only kind of works as when I move my mouse near that edge in NoMachine, it still opens the Windows taskbar again.
    #34553
    AvatarBritgirl
    Keymaster

    Hi,

    regarding point 1 in your last reply, you should take a look at https://knowledgebase.nomachine.com/FR11R04044, which is under review, although function keys for changing brightness (which you mentioned in the first post) have not been considered. May I ask why you would need to control brightness?

    Point 2 – We’re checking this.

    Point 3 – We’re checking this.

    Point 4 – For 4k displays we have the following planned,  https://knowledgebase.nomachine.com/FR02M02864 and also https://knowledgebase.nomachine.com/FR12R04056.

    Point 5 – Another FR in our roadmap. This looks like https://knowledgebase.nomachine.com/FR10M02977

    Point 6 – We’re checking this as well and will come back to you 🙂

     

    #34555
    AvatarBritgirl
    Keymaster

    Some updates. Regarding Point 6, we didn’t find a way to reproduce it, but we’ve found some old Windows users reports about similar issues occurring with other software (not NoMachine). Sometimes killing the explorer.exe process and restarting it works around the issue, but usually the solution consists in understanding the tool or process that is causing such taskbar behaviour and uninstalling it.

    For us to investigate the remaining points, can you confirm what the specific OS version is on the 2018 macbook you mention? (On the Macbook 2014 you say you’ve installed Big Sur but didn’t mention what’s on the other computer 🙂 ).

    Regarding point 2 specifically, is the behaviour there regardless of the application you are using? Can you check whether without oldeventapi set the problem persists on both machines?

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.