German keyboard layout

Forums / NoMachine for Raspberry Pi / German keyboard layout

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #25622
    Avatarhans
    Participant

    Hello,

    ::: Raspi 4 debian buster
    ::: NoMachine 6.9.2

    how do I solve the problem in NoMachine with the German key word “üöä” etc. ?

    thnx for help
    Hans

    #25626
    AvatarBritgirl
    Keymaster

    Can you confirm that you have 6.9.2 on both the client and the server side? Is the Raspberry on the server side, client side or both? What characters are showing up instead?

    #25642
    Avatarhans
    Participant

    hi Britgirl,

    both sides  client and server have 6.9.2

    characters (client = linux-xubuntu) = (server = raspi4 debian buster)

    ö =; Ö=: ä=’ Ä=” ß=- ü[ ü={ :=>

    on the Raspi …Raspberry-Pi-Konfiguration :  / Lokalisierung / Taststur festlegen:  “Generic 105-key PC(intl) /German/German

    is set.

    but(!) if i use sudo raspi-config:

    4) LocalisationOptions… / I3 Change Keyboard Layout … then “reloading keymap” is shown and   then it breaks.

     

    ##Hans

     

     

     

     

    #25649
    Avatargraywolf
    Moderator

    Server’s keyboard defaults to US.

    You would setup DE keyboard in the server’s display: setxkbmap -layout de. Otherwise change it by the keyboard configuration preferences of the graphical environment on the server.

    #25650
    Avatarhans
    Participant

    Hello graywolf,
    problem solved
    Thanks for your help 🙂
    Good service
    please consider including this solution in FAQ if not already done
    bye Hans

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.