GPU Usage High – RTX 2080 Ti graphics card

Forums / NoMachine for Windows / GPU Usage High – RTX 2080 Ti graphics card

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #32673
    AvatarRemowylliams
    Participant

    I’ve been experiencing what I consider high gpu usage with the latest version of NoMachine 7.1.3. even with the screen minimized I was seeing 32% GPU usage. I would expect the nvidia encode and decode to show usage but not according to Windows 10.

    Is this normal? I did notice upgrading the machine I connect to’s Linux NoMachine server to 7.1.4 seemed to lower the GPU usage after a short time but still chews up about 10% so that’s a good thing. I use to be able to keep NoMachine up all the time.

    For clarity, I didn’t see this behavior till I upgraded my workstation which connects via client to my Linux machine. The Linux machine is using a GTX 1080 GPU.

    I can see where it might be a problem in the nvidia driver on my workstation but just now it seems upgrading for the Linux has helped at least when I don’t have an active screen happening in my NoMachine client.

    Any insight into why the GPU load would be appreciated I’m sending a snapshot of Task Manager window. This was with an active client as I said after updating on my remote machine. GPU drops off quickly to about 10% The updated idle shows idle and then the load after closing my NoMachine client screen.

    Many thanks for a very useful software.

    Remo

    #32792
    Avatarfra81
    Moderator

    Hi Remo,

    I don’t see anything abnormal here. Tto reduce the GPU usage, you can try to check the ‘Disable client-side image post-processing’ and ‘Disable multi-pass display encoding’ options in the Display setttings in the session menu panel, but this is not necessarily what you want. To stop the NoMachine player from using the GPU completely, you would need to check instead the ‘Disable client side hardware decoding’ option. At this point the software fallback will be used, though fully optimized.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.