Graphics corruption after connecting

Forums / NoMachine for Linux / Graphics corruption after connecting

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #19632
    zaggynl
    Participant

    When connecting to my PC running NoMachine I notice colored bars/artifacts, screenshot:

     

    http://i.imgur.com/bV9eiPp.png

     

    These are not visible on the monitors so it isn’t my video card dying.

    I’m running Ubuntu 18.04 with https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

    Everything in NoMachine is working fine.

    #19639
    jradxl
    Participant

    I’ve seen same effect on two different headless servers recently upgraded to 18.04, and using the Mate Desktop.

    Even created a brand new account to see if that was issue – no.

    However, after “fiddling around” with resolutions, backgrounds, and reboots, it has gone away on both.

    I think it’s because the NoMachine client can’t find the right resolution…

    Try CntrlAlt0 and force other resolutions, use Displays to set other resulting, and keep trying!

    By the way, I’m using NoMachine to create a virtual desktop, as there is no monitor, and Lighten is set to seat default desktop false

    Hope that helps

    John

     

    #19642
    zaggynl
    Participant

    Thank you for replying John, I tried setting custom resolutions that match the resolution of the monitors and the artifacts changed to black.

    #19664
    jradxl
    Participant

    I just upgraded another VM to 18.04, and experienced the same effect. I switched down to 1600×1200 and the problem went away. Then switched back to 1920×1080 and the problem was still gone. Perhaps you have a different problem – you could try installing Mate to see if that gives you same problem

    John

    #19669
    graywolf
    Moderator

    As far as I understand, on the left there is a smaller monitor. So the garbled part is not normally visible on the physical screens.

    When viewing all monitors, you can see that part because NoMachine captures the whole “virtual” screen. I think the graphics stack doesn’t even care of updating that part that is not normally visible.

    We should improve this by setting a black background on all areas that are not visible in any monitor:
    https://www.nomachine.com/TR09P08855

    #19681
    zaggynl
    Participant

    Indeed the left monitor is a smaller one, 12801024 vs the right one at 1920×1080.
    The artifacts returned while settings remain the same, it appears I currently do have to change settings around until the black bars disappear.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.