Graphics distorted

Forums / NoMachine for Linux / Graphics distorted

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #13566
    Avataramazon
    Participant

    Hey!

    Im running a Ubuntu 14.04 server at Amazon’s EC2 and have got so far as to get the connection with NoMachine up and running. Am able to log in to my user account on the remote server. Something is though causing problems with the graphics in many applications. It seems that the problem is related to the colour depth of the program. Programs such as Firefox will have all the window content all distorted and unusable, while the window borders and menus look just fine. Also the background of the desktop is full of vertical lines if not set to black.

    Now I can’t figure out how to fix this problem. I don’t know if the solution is to lower the colour depth on the remote server side (not desired solution) or to somehow change the NoMachine at the local side (running OSX 10.11.6) to handle the colour settings.

    Some programs won’t run at all due to this problem.

    I’m using Version: 5.1.62_1 for the remote server side on Ubuntu 14.04 – Free version

    Local side Version 5.1.62 as well on Mac OSX 10.11

    No physical display at remote location

    Tried using GNOME and Xfce on remote server – same problem on both, except more problems in Gnome.

    Thanks for developing such a great program in general! 🙂 All help appreciated.

    #13577
    Avatarfra81
    Moderator

    Hi!

    We were not able to reproduce this problem with a similar environment.

    Please attach the output of the ‘xdpyinfo’ command run inside the Ubuntu machine.

    Also NoMachine logs could be useful. You can find here instuctions on how to gather server side logs here: https://www.nomachine.com/DT07M00098. You can send them to forum[at]nomachine[dot]com.

    #13582
    Avataramazon
    Participant

    Email sent to forum[at]nomachine[dot]com.

    Included all the logs, .nx files and outputs from xdpyinfo.

    Awaiting reply.

    Cheers!

    #13588
    AvatarBritgirl
    Keymaster

    Hi, checking the logs you sent it, they are from the client-side. We need them from the server side (the machine you are connecting to during the session).

Viewing 4 posts - 1 through 4 (of 4 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.