Green bars and ghost images on remote screen

Forums / NoMachine for Linux / Green bars and ghost images on remote screen

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #42129
    freya93
    Participant

    Dear NoMachine team,

    I’m connecting to a remote Ubuntu 20.04 machine, from my Pop OS 20.04 computer, both machines running NoMachine 8.2.3. Whenever I connect to the remote machine, I get weird ghost images on the desktop GUI and a big band of green at the top. Images are below. The image corruption worsens as I start to open windows or move the mouse. However I can connect to this machine remotely from a Macbook using NoMachine with no display issues. Is there anyway to address this issue?

    Cheers,

    F.

    #42152
    katpan
    Participant

    Hello,

    Please try to disable hardware decoding and let us know it that worked

    #42159
    freya93
    Participant

    Hi,

    I’ve tried that and it has not fixed the problem.

    #42162
    katpan
    Participant

    Hi again!

    In order to investigate, we need the logs from server side.

    More info on how to collect logs here in this article: https://kb.nomachine.com/AR10K00697

    Can you please send them by email to forum[at]nomachine[dot]com, making sure to reference the topic as the subject of the email?

    Thanks!

    #42212
    Britgirl
    Participant

    Server logs look clean. We would need the Player side logs, from the client machine you are connecting from.

    These are uptodate instructions for extracting the logs we need: https://kb.nomachine.com/DT07S00244

    Also, you say you disabled HW decoding. How did you do that? It needs to be disabled completely on the Player side in the player.cfg file.

    Edit the file $HOME/.nx/config/player.cfg and set the configuration key “Enable hardware accelerated decoding” to “disabled”. Before changing the configuration key, you should first quit the NoMachine Player (you can do this by right clicking on the !M icon in the system tray and selecting ‘Quit NoMachine Player’.) Then, try to connect again.

    If you’ve done this and still encounter the issue, then send Player logs as I just mentioned.

    #42393
    freya93
    Participant

    Ok I’ve updated the config file (previously I was just altering it in the Settings GUI for NoMachine, and I think it was resetting every time I reopened the program. This has fixed the ghost image issues, however now my connection to the remote machine is incredibly laggy. The mouse takes several minutes to move or respond. Is there no way around this without disabling hardware acceleration?

    #42820
    Britgirl
    Participant

    however now my connection to the remote machine is incredibly laggy. The mouse takes several minutes to move or respond.

    It’s strange that lagginess would be caused by disabling hardware acceleration (which would mean falling back to software acceleration). Did you send us the Player logs as requested? Tick the box “Don’t delete logs on exit” in Security of the Player settings. Start a session, reproduce the behaviour and submit them as before.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.