Green screen/hardware decoding problem

Forums / NoMachine for Linux / Green screen/hardware decoding problem

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #27526
    Avatarberilevi
    Participant

    I saw another thread about the same issue I have but it was closed without a solution.

    Until updating NoMachine to the latest version today I had no issue. However after updating it, I am getting a full green login screen. The issue is %100 reproducible and turning off the hardware decoding fixes the problem.

    I am running Ubuntu 18.04.4 LTS with XFCE desktop and all packages updated as of today.

    Client is a windows 10 PC.

    The logs from the client pc is attached.

     

    Attachments:
    1. nx-1.zip
    #27536
    AvatarBritgirl
    Keymaster

    I don’t know which topic you are referring to but there are two similar ones open here:

    Green screen after updating to 6.10.12

    Green screen after updating to 6.10.12

    Please follow either of those links for the Trouble Report.

    #27635
    Avatarfra81
    Moderator

    Do you have both a Nvidia card and the Intel integrated graphics? Can you try to use a different card for NoMachine in the Nvidia control panel? And which one is in use now?

    #27636
    Avatarberilevi
    Participant

    I only have nvidia graphics card. This is on the client side.

    Are you asking for the server side or the client side?

    #27641
    Avatarfra81
    Moderator

    Yes, I’m asking for the client side. So you have an AMD CPU (or the integrated card is disabled in BIOS)?

    #27643
    Avatarberilevi
    Participant

    It’s Intel cpu, there is no integrated gpu card.

    #27697
    Avatarfra81
    Moderator

    Further investigations identified two different issues. One is in the Intel drivers, occurring when the monitor on the client machine has a resolution higher than FullHD (1920×1080). That seems to be fixed in the last drivers but it doesn’t look to be your case.

    Another issue was found in the NoMachine software, only occurring when the server machine has multiple monitors. This will be fixed in the next release, but if you wish to test a preliminary patch, just send an e-mail to forum[at]nomachine[dot]com to receive it.

    #27801
    AvatarBritgirl
    Keymaster

    Everyone, please refer to:

    Green screen when connecting by NoMachine client for Windows v. 6.10.12 to high resolution monitors
    https://www.nomachine.com/TR05R09689

    You can sign up to receive notification when a fix has been made available.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.