Grey screen at GDM login page on-Fedora 36 with Wayland

Forums / NoMachine for Linux / Grey screen at GDM login page on-Fedora 36 with Wayland

Tagged: , , ,

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #38793
    Volkerball
    Participant

    So I am running Fedora 36 on Nvidia machine with default Wayland. When I set /usr/NX/etc/node.cfg to:

    • EnableEGLCapture 1
    • WaylandModes “egl,drm,compositor”

    I get grey screen both before login and after login. Both keyboard & mouse work, but I can not see anything on screen.

    If I change it WaylandModes to “drm,egl,compositor”, then I get question if I want to start desktop session. If I choose yes, then it starts x11 session, which tbh is not what I want. Otherwise, it is same behavior as previous one – gray screen with working mouse & keyboard both before login and after.

    Finally, I have found that:

    • EnableEGLCapture 1
    • WaylandModes “compositor,egl,drm”

    still gives grey screen behavior before logging in. But if I already logged in, then it connects to Wayland session and functions properly. Since it requires previously logged-in session then I decided to set up aut0-login:

    • /etc/gdm/custom.conf
    • [daemon]
    • AutomaticLoginEnable=true
    • AutomaticLogin=username

    Hence, I can avoid login screen, which gives me grey screen. Unfortunately, it is still kinda janky and if log out from gnome session, then I will get grey screen again. But I wonder is there a proper way to make NoMachine work with Wayland? Or is my janky workaround is the only way to avoid that grey screen at login page?

    P.S. I am not interested in x11 workarounds.

    #38823
    Britgirl
    Participant

    Hi, thanks for taking the time to report this. We have yet to add Fedora to our officially supported list and will do soon. Initial tests have not shown similar issues, so we will need logs from you of the two cases you are describing 🙂 I take it you are using the NoMachine v7.9.2 both sides? Reproduce and submit logs

    1) of when you get the grey screen when connecting to the login window
    2) in the moment you start the desktop session after having changed WaylandModes to “drm,egl,compositor”.

    For instructions on how to enable logs, please see this guide:
    https://knowledgebase.nomachine.com/DT11R00182

    You can send both sets as attachments to an email to forum[at]nomachine[dot]com. Please insert the title of the topic in the subject of your email. Thanks!

     

     

    #38902
    Volkerball
    Participant

    While I already sent logs to email address, I played around a bit with configurations and found out that in my case only “WaylandModes compositor” works. It does not matter if EGLCapture is turned on or off, basically every other combination will give gray screen on both on GDM and Gnome Desktop. It confuses me, since every other thread or KB suggest enabling EGLCapture and setting WaylandModes to egl or drm. I guess it is typical “it works on my machine” problem, but in my case it is opposite—”it does not work on my machine”.

    #38915
    Britgirl
    Participant

    We’ll check this out, but in the meantime, can you tell us the result of the command:
    sudo netstat -anlp | grep egl

    #38937
    Volkerball
    Participant

    Huh, I got nothing:

    [Volkerball@fedoradesktop ~]$ sudo netstat -anlp | grep egl
    [sudo] password for Volkerball:
    [Volkerball@fedoradesktop ~]$
    #38947
    Britgirl
    Participant

    This means that EGL capturing isn’t enabled.

    Tell us the output of sudo /etc/NX/nxserver --egl-capture yes

    Please also attach the modified scripts mentioned in the output of the command above.

    Also, what is the output of getcap /usr/bin/gnome-shell?

    #39112
    Volkerball
    Participant

    This means that EGL capturing isn’t enabled.

    Tell us the output of sudo /etc/NX/nxserver --egl-capture yes

    I see. sudo /etc/NX/nxserver --egl-capture yes not only changes /usr/NX/etc/node.cfg, but also make some changes in GNOME`s config files and forces x11. Basically right now the only solution is turning off Wayland…

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.