Guide on disable copy-on-select feature

Forums / NoMachine for Linux / Guide on disable copy-on-select feature

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #40173
    zhenyus
    Participant

    Hi,

    I asked about the “disable copy-on-select” feature in https://forums.nomachine.com/topic/upvote-for-feature-disable-copy-on-select#post-38485, and received an answer that it would be included in version 8. Now version 8 is out, I checked the configurations and didn’t find this feature. Can anyone let me know how to use it?

     

    Thank you.

    #40247
    Britgirl
    Participant

    With the release of version 8, a new option in the client connection file (.nxs) allows to enable/disable the update of the local clipboard when a text is selected inside the NoMachine session. This option is named “Disable updating clipboard on mouse selection” and accepts value “true” or “false” which is the default.

    This setting applies to connections from Window and macOS to Linux (physical desktop, virtual desktop and custom sessions).

    #40248
    zhenyus
    Participant

    Thank you, that works perfectly.

    #40875
    danahow
    Participant

    Hi, on Windows I’m running NX 8.1.2 and it says it’s up-to-date. I’m connecting to CentOS Linux release 7.9.2009 (Core).

    On the Linux machine, it reports:

    $ /usr/NX/bin/nxserver --version

    NoMachine Terminal Server Subscription – Version 7.10.1

    My problem? I want copy-on-select, but right now copy happens only if I right-click and select Copy. This is annoying.

    I would also like something simple like double-click leading to paste. Having to go through a menu for both Copy and Paste is time consuming for my use case.

    I located “Disable updating clipboard on mouse selection” in Documents/NoMachine/.nxs and tried “true” and “false”. Both produced the current behavior: Copy and Paste must both go through a menu; I couldn’t get copy-on-select behavior.

    What else should I try?

    Thanks

    #41536
    Britgirl
    Participant

    The key, available in version 8 .nxs files, is also applicable for users connecting to version 7 Linux servers, but the direction of the copy and paste must be from Windows client in your case to Linux server. What is the direction of the clipboard, from Windows to Linux server?

    #41571
    Britgirl
    Participant

    How does one enable/specify and then perform copy-on-select inside NX 8.1.2?

    The key that the original user was asking about disables the update of the local clipboard when a text is selected inside the NoMachine session. You can see the original request here:

    Add an option to disable copy-on-select

    This key cannot be used to enable or disable ‘copy on select’ in general, which is a configuration at the system level.

    Therefore, setting the key to ‘true’ and bearing in mind what I wrote earlier (that this setting applies to connections from Window and macOS to Linux physical desktop, virtual desktop and custom sessions),  a typical scenario would be:

    1. Select text to be copied using your local operating system’s copy method
    2. Move to session window where Linux desktop is running
    3. Highlight text which needs to be replaced
    4. Press “Ctrl + V” to paste

    If your mouse does not have a middle button which you can use to paste with, you can press the left and right buttons together to emulate the middle button in the NoMachine session.

    If this doesn’t help and you are still having problems, I noticed your connecting to a NoMachine Terminal Server which has support options available. It might be better if you open a support enquiry and let our support team check your set-up further.

     

     

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.