H.264 lib setup – help request

Forums / NoMachine for Linux / H.264 lib setup – help request

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14973
    ryoko227
    Participant

    So the server is being run on Win10Pro64 with a MSI GTX960. It is a VM, however it is under unRAID with GPU pass-through and using up to date nvidia drivers. Also, Steam In-home Streaming runs using GPU acceleration and NoMachine’s Connection Settings => Performance: have H.264, 30FPS, and Use Acceleration all checked. So I’m going to assume that the hardware based H.264 encoding is happening correctly on the server side.

    The client (which is where I am also assuming) is having the decoding issue, is an ancient dell 17 n7010 running LM KDE 18.1. It has ffmpeg preinstalled and is fully up to date. Here are the steps that I took to install the libs following the instructions outlined here. https://www.nomachine.com/AR10K00696 .

    Via terminal $ locate libavcodec

    /usr/lib/x86_64-linux-gnu/libavcodec-ffmpeg.so.56.60.100 was where the file was found, so I $ sudo mc and found the folder and file.

    I then copied libavcodec-ffmpeg.so.56.60.100, libavutil-ffmpeg.so.54.31.100, and libswresample-ffmpeg.so.1 to /usr/NX/lib as libavcodec.so, libavutil.so, and libswresample.so

    I also tried changing the properties to be similar to the other libs (executable was the only difference) when H.264 didn’t work. Have also tried restarting both systems just to make sure there wasn’t an issue there. No matter what I have done, Display settings always show as – Display 1600×900, codec VP8, audio Opus 22kHz stereo

    I feel like I’m missing something, or doing something wrong. Are those even the correct lib files to be copied over? Any suggestions or help would be appreciated πŸ™‚ Thank you!

    Client – NoMachine Free, 5.2.21 Linux / Linux Mint 18.1 KDE

    Server – NoMachine Free, 5.2.21 Windows / Windows 10 Pro 64 (1607 14393.1198)

    #14985
    Britgirl
    Keymaster

    To check if it’s a decoding issue you can look in your Linux client session log (.nx/R-*) and see if either the following is printed:

    Info: H264 support is available.

    or

    Info: H264 support is not available.

     

    #14986
    ryoko227
    Participant

    Hello Britgirl!

    Thank you for your response, I checked the log and it states “Info: H264 support is not available.” So does this mean that the decoding side or encoding side is having an issue? Where do we go from here?

     

    P.S. – Did you get my email reply to your message? I replied toΒ forum[at]nomachine[dot]com but don’t know if you received it. πŸ™‚

    #14989
    Britgirl
    Keymaster

    we did get your email πŸ˜‰

    as for the message, something went wrong when you set it up. Instead of copying, just do symlinks

    cd /usr/lib/x86_64-linux-gnu/
    ln -s libavcodec-ffmpeg.so.56.60.100 libavcodec.so
    ln -s libavutil-ffmpeg.so.54.31.100 libavutil.so

    If that doesn’t change anything, remove symlink: rm /usr/NX/lib/libstdc++.so.6

    and try again.

    #14990
    ryoko227
    Participant

    I tried adding the symlinks that you suggested and same result. Buuuuuuuut, remove symlink: rm /usr/NX/lib/libstdc++.so.6 got h.264 up and running!

    Thank you very much Britgirl! πŸ™‚

    #14992
    Britgirl
    Keymaster

    So you should now be showing ‘Info: H264 support is available’ in the session logs, and in the menu’s Display Settings, you should not see VP8 as the codec, but H.264.

    Let us know how you get on with the games πŸ˜‰

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.