H.264 not working in Ubuntu 14.10b2 client

Forums / NoMachine for Linux / H.264 not working in Ubuntu 14.10b2 client

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4948
    Avatarfidelleon
    Participant

    I’m testing Ubuntu 14.10 beta 2 (Xubuntu i386) in my client desktop and I’m unable to make X.264 codec work. As usual, I have followed the instructions (libavcodec.so and libavutil.so in my /usr/NX/lib’s client) but all I get is the VP8 codec.

    Interestingly enough, I have built a QEMU VM with Ubuntu 14.04, installed NoMachine, put both libraries in /usr/NX/lib, and I can connect to my host with the H.264 plugin, so it seems to me there’s “something” in Ubuntu 14.10 preventing H.264 to work.

     

    #4959
    Avatarfra81
    Moderator

    Could you please verify the version of your libavcodec and libavutil libraries?
    You can do this by listing files in their install directory, e.g.:

    $ ls -l /usr/lib/libav*

    Currently NoMachine supports avcodec library up to major version 55. If you have the newest version (which is 56), you should downgrade your libraries to use it with NoMachine. Support for version 56 is being added.

    #4995
    Avatarfidelleon
    Participant

    That’s what I suspected, so I downloaded the ffmpeg package from NoMachine.com/opensource and did my best to compile it (./configure && make wasn’t working), to no avail…

    $ ls -l /usr/NX/lib/libav*
    -rwxr-xr-x 1 root root 2366788 oct 14 22:40 /usr/NX/lib/libavcodec.so
    -rwxr-xr-x 1 root root 2366788 oct 14 22:40 /usr/NX/lib/libavcodec.so.54
    -rwxr-xr-x 1 root root  484216 oct 14 22:41 /usr/NX/lib/libavutil.so
    -rwxr-xr-x 1 root root  484216 oct 14 22:41 /usr/NX/lib/libavutil.so.51

    but it’s very likely I didn’t compile it right O:-)

    As far as I see, Ubuntu 14.10 does indeed pull libavcodec56 (libavcodec54 is obsoleted):

    # apt-get install libavcodec54
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Package libavcodec54 is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source

    E: Package ‘libavcodec54’ has no installation candidate

    Well, it’s not a stopper for me, so let’s have some patience 🙂

    #5472
    AvatarBritgirl
    Keymaster

    Support for version 56 is being added

     

    It has since been added. I suggest you update to the latest packages.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as solved, you can't post.