Hardware encoding failing

Forums / NoMachine for Linux / Hardware encoding failing

This topic contains 5 replies, has 2 voices, and was last updated by Avatar fra81 1 month, 3 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #23260
    Avatar
    TheFlu
    Participant

    SYSTEM

    • Version: 6.7.6
    • OS: PopOS 19.04 / Ubuntu 19.04
    • GPU: GTX 1080
    • Driver: 430.34

    NoMachine Settings

    • EncodingL H264
    • FPS: 30
    • Acceleration: On

    Log

    NvSetParameters: ERROR! Failed to initialize encoder.

    NvSetParameters: ERROR! Error is 8, ‘Invalid parameter’.

    NvInitVideoStreams: WARNING! Failed to initialize video stream [0].

    Info: Using H.264 software encoder.

    20982 21466 12:02:30 298.858 Writer/Writer: WARNING! Buffer for FD#34 reached 317358 bytes.

    20982 21465 12:02:30 506.410 Writer/Writer: WARNING! Buffer for FD#34 reached 279340 bytes.

     

     

    #23271
    Avatar
    fra81
    Moderator

    Hi,

    can you please send all the logs. Whole ‘/usr/NX/var/log’ directory if possible. You can send it to forum@nomachine.com.

    #23284
    Avatar
    TheFlu
    Participant

    Logs have been emailed

    #23293
    Avatar
    fra81
    Moderator

    You seem to have two 4K monitors, that give the total screen size reported in the logs:

        Info: Using screen size 7280×1080.

    Unfortunately NVENC (Nvidia’s encoder) supports up to 4K, as you can see here:

    https://developer.nvidia.com/nvidia-video-codec-sdk#NVENCFeatures

    However this Feature Request, when implemented, will address your case:

    https://www.nomachine.com/FR05N03113

    For the records, you can see that the hardware encoder is used when there is a single monitor:

        Info: Using screen size 3840×1080.
        Info: Using Nvidia H.264 hardware encoder.

     

    #23298
    Avatar
    TheFlu
    Participant

    Is there a way to make it use only 1 monitor? I currently have two 1920×1080 and one 3440×1440. The biggest problem I am running into is artifacts on the screen when using NoMachine and I was thinking this would go away if I was using harware encoding and it crushing my CPU.

     

    #23324
    Avatar
    fra81
    Moderator

    At the moment, the only way not to use all monitors is unplugging them physically from the server. Artifacts could be due to a bug in the H.264 software encoder with such a high horizontal resolution. Please try to use a different codec: open Server preferences -> Performance tab, check ‘Use a specific display encoding’ and make sure VP8 is selected, then restart the server and connect again.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.