Headless server

Forums / NoMachine for Linux / Headless server

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #32684
    Avatarkdv666
    Participant

    Firstly, the important bits:

    OS: Ubuntu -Mate 20.04.2
    NoMachine 7.4.1

    I installed NoMachine on both client and server machines, and got it running perfectly over my home network.  No problems at all.

    Then, I ran the server machine in a headless configuration, i.e. no mouse, keyboard, monitor.

    Problems:
    When the desktop (which has been set for fullscreen (1920×1080)) opens, it is significantly smaller both horizontally and vertically. Around it the rest of the window is black.

    Also, both the keyboard and mouse clicks are very slow to respond … a lag of at least one second.

    I’ve tried to read the relevant docs, but I haven’t found any help.  I’d very much appreciate help.

     

    #32701
    Avatarfra81
    Moderator

    Hi,

    the problems you see are not caused by NoMachine and are described in this article:

    https://www.nomachine.com/AR03P00973

    You may try with a dummy HDMI display adapter or the suggestions at point 2) of the article.

    #32702
    Avatarkdv666
    Participant

    Thank you very much!  I was hoping to be pointed in the right direction, and you have done so.  I really appreciate your taking the trouble to get back to me so quickly!

    Not sure why that article didn’t come up when I searched the knowledgebase for  “headless”.  Hopefully, your reply may help others in the future.

     

    #32703
    Avatarkdv666
    Participant

    Yup.  The “systemctl stop lightdm” followed by a server restart worked like a charm.

    For good measure, I added a “systemctl disable” to the mix so I wouldn’t run into the same problem after the next reboot.

    Cheers!

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.