Hide mouse cursor and change modifier keys

Forums / NoMachine for Windows / Hide mouse cursor and change modifier keys

Tagged: ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #10617
    rob8861
    Participant

    Hi Peeps,

    I running the latest NoMachine to connect from my Windows 10 to my Mac (running El Capitan)

    Everything seems to be working great but I have two issues that are more of an inconvenience than an actual issue.

    1. right now when I connect to my Mac, I see two mouse cursors. The one with the lower Z index is the Mac’s cursor and it often changes its shape (arrow, hand, caret etc). The other one is the windows cursor. Is there a way I can hide the Windows cursor and only see the Mac’s one. otherwise, it looks like the Mac’s one is always dragging behind the Window’s one.

    2. Since I don’t have anything connected to the Mac besides the power cord, it thinks I have no keyboard, mouse or monitor setup. As a result, when I try to go into Keyboard -> Modifier keys  to change the cmd to ctrl , it automatically resets it back to default. I am assuming it does that because it sees no keyboard connected. Is there a way to do that via NoMachine so I can use the ctrl key as the Command key when I am connected to my Mac.

    Thank you,

    NoMachine version: the latest free version
    I am connecting to a virtual display

    #10628
    graywolf
    Moderator

    Hello.

    When no monitor is attached to the Mac the graphics card is turned off and everything is rendered in a software frame buffer. The cursor image is drawn in the frame buffer as well so that you see the double cursor. Searching the web for “headless hdmi dongle” provides interesting results about keeping grahics hardware on using a fake monitor.

    About the key remapping issue, I’m afraid that keeping a keyboard attached to the Mac would not help. NoMachine ignores that “swap modifiers” options from Mac. I’m going to open a trouble report about that situation.

    #10634
    rob8861
    Participant

    Hi

    Thank you very much for the quick reply.

    Since I am using a headless mac mini, I am certainly going to buy the headless hdmi dongle.

    As for the key mapping, it would certainly be a nice feature since I use a PC keyboard and used to ctrl being the main modifier.

     

    Thank you.

     

     

    #10664
    graywolf
    Moderator

    A Trouble Report has been opened: https://www.nomachine.com/TR03N06649

    Check “Notify me when the TR is closed” to receive an alert when a fix is available.

    #10671
    rob8861
    Participant

    Hi graywolf,

    I went ahead and bought the headless HDMI and it indeed did the trick. I no longer see the trailing mouse pointer and it responds a lot faster now. However, even though my display settings are set to 1080p or (1920×1080) , in both the client and remote, the resolution does not look as crisp as it would if I connected my mac to a real display. Often times, I would see some blurriness for a split second and then it turns sharp again (similar to how images are loaded in the browser). For example, if I grab a window (like the Finder) and drag it around, while being dragged it tuns slightly blurry, and then when I let it go, it turns crisp again.

    I am connected via a wifi so I am wondering if connecting my machine locally via a crossover cable can improve the overall crispness of the display. I tried playing around with the settings under Performance but didn’t really notice any major change so I left them all unchecked.

    awaiting your repose.

    Thanks
    Rob

    #10698
    graywolf
    Moderator

    Set quality at the highest value and check “Disable multi-pass display encoding”.

    #10700
    rob8861
    Participant

    Here is what I have done so far.

    • I moved the quality bar all the way to the right.
    • I checked all the options on the right side in the display settings (multi-pass, network adaptive and buffering).
    • I also enabled “request frame rate” and set it to 60
    • and also “use GPU acceleration”
    • I changed the connection type from wifi to a local cross over cable connection.

    To be honest, besides some noticeable performance improvements, I haven’t noticed any major video/image quality improvements.

    When I tried to change the codec from vp8 to h264 , it switched it back to vp8. Is there any big difference between the two?

    thanks,

    #10799
    graywolf
    Moderator

    With h264 image quality can improve but you need to enable it. Here you can find useful information: https://www.nomachine.com/AR10K00706

    #17499
    Britgirl
    Keymaster

    UPDATE: the behaviour is expected, thus the TR has been closed. In its place a Feature Request has been opened:  https://www.nomachine.com/FR03N03087

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as closed, you can't post.