Hiding the Monitor icon and balloon messages from the system tray

Forums / NoMachine for Windows / Hiding the Monitor icon and balloon messages from the system tray

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #38721

    Dear Support,

    First of all, thank you for your powerful software.

    I have three main problems that still remain unresolved after checking on your site and are as follows:

    We want no notifications or prompts to be displayed on the client computer after connecting. We also configured the Node.cfg file in Windows 10, which I attached to the photos, but unfortunately, it does not change anything.

    We even disabled the icon of NoMachine software through Windows Taskbar, but it still displays.

    Please advise us.

    Best Regards,

    Alex Rezaee,


    We aren’t aware of issues with disabling the !M icon and notifications. We checked on the fly to make sure. When changing either of those keys, you need to restart the machine. Did you restart? The player also has a service icon which becomes visible when you open NoMachine, to start a connection for example. See 3.3. Quit NoMachine Player in the Connection Monitor Guide: https://knowledgebase.nomachine.com/DT11R00202#3.3

    Balloon messages, which are used to notify (e.g someone has connected/disconnected) as well as prompt the desktop user to accept a specific function (e.g accept an incoming connection), are a central security feature of NoMachine software. You should know that whilst in version 7 it is possible to disable all balloon messages using the appropriate key in node.cfg, in version 8 the disabling of all balloon messages will no longer be possible.

    In the next major we have maintained the possibility to show/not show the !M service icon in the system tray (like it is in version 7) but notification messages will still be displayed since they are independent from the !M icon. We will see in the future which notifications will be possible to disable on an individual basis, but to disable all will not be an option, as I said, for security reasons.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.