High CPU load for 7.6.4

Forums / NoMachine for Linux / High CPU load for 7.6.4

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #37370
    jeremy.fix
    Participant

    Hi,

    We have NoMachine installed on a bunch of machines and I just noticed that, for some of them, there is a high load;

    The responsible process is /usr/NX/bin/nxclient.bin --update download --background for all the machines with a high load. For example, right now I notice the following :

    host46:~:myuser$ ps aux | grep nxclient
    root      115419  136  0.0 640892 23992 ?        Sl   Feb05 4041:36 /usr/NX/bin/nxclient.bin –update download –background

    We have NoMachine v7.6.2-4 ;

    I noticed someone related an issue there

    If I check the strace as requested in the post, I see a lot of

    20:44:08.048497 pselect6(4, [3], NULL, NULL, NULL, {[HUP INT USR1 USR2 PIPE ALRM TERM CHLD TSTP TTIN TTOU VTALRM WINCH IO PWR], 8}) = 1 (in [3])
    20:44:08.048544 futex(0x7f0af400d5a0, FUTEX_WAKE_PRIVATE, 1) = 1
    20:44:08.048587 pselect6(4, [3], NULL, NULL, NULL, {[HUP INT USR1 USR2 PIPE ALRM TERM CHLD TSTP TTIN TTOU VTALRM WINCH IO PWR], 8}) = 1 (in [3])
    20:44:08.048632 futex(0x7f0af400d5a0, FUTEX_WAKE_PRIVATE, 1) = 1

    or

    20:43:56.585927 futex(0x7f0af400d5a0, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, NULL, FUTEX_BITSET_MATCH_ANY) = 0
    20:43:56.585988 futex(0x7f0aec002120, FUTEX_WAKE_PRIVATE, 1) = 0
    20:43:56.586021 futex(0x7f0af400d5a0, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 0, NULL, FUTEX_BITSET_MATCH_ANY) = 0
    20:43:56.586081 futex(0x7f0aec002120, FUTEX_WAKE_PRIVATE, 1) = 0

    Actually ,  I dumped the strace for , say 20 minutes or so and they ended up to be of 6.5GB and 4.2GB  🙂

    These are the strace for 2 PIDS (115443 and 115442) with high %CPU; The top output is, repeatedly :

    top – 20:03:03 up 6 days,  1:21,  1 user,  load average: 1.35, 1.54, 1.50
    Threads:   8 total,   2 running,   6 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  0.7 us,  2.4 sy,  0.6 ni, 95.1 id,  0.7 wa,  0.0 hi,  0.4 si,  0.0 st
    MiB Mem :  64045.3 total,  60574.1 free,   1045.2 used,   2426.0 buff/cache
    MiB Swap:   2048.0 total,   2048.0 free,      0.0 used.  62359.0 avail Mem

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
    115443 root      30  10  640892  23992  19844 R  72.4   0.0   2158:31 nxclient.bin
    115442 root      20   0  640892  23992  19844 R  63.5   0.0   1888:19 nxclient.bin
    115419 root      20   0  640892  23992  19844 S   0.0   0.0   0:00.06 nxclient.bin
    115427 root      30  10  640892  23992  19844 S   0.0   0.0   0:00.00 nxclient.bin
    115437 root      20   0  640892  23992  19844 S   0.0   0.0   0:00.00 nxclient.bin
    115439 root      30  10  640892  23992  19844 S   0.0   0.0   0:00.00 nxclient.bin
    115440 root      30  10  640892  23992  19844 S   0.0   0.0   0:00.00 nxclient.bin
    115441 root      30  10  640892  23992  19844 S   0.0   0.0   0:00.00 nxclient.bin

    From the name of command, I suppose there might be some stalling downloads ? Is there anything I can do ? Is just restarting the nxserver sufficient ?

    Thanks for your help,

    Jeremy.

    #37445
    Britgirl
    Keymaster

    Hi, can you send us the logs of the M- directories from the affected hosts (typically you can find them in /var/NX/nx/.nx/M-* ) ?

    Attach them here or send direct to forum[at]nomachine[dot]com.

    #37449
    jeremy.fix
    Participant

    The requested log is attached;

    There was only one M- directory  : M-localhost-115419-1011237CFD0B60DBDDA3CF14128E27C5  with one session file inside .

    Note that I stopped yesterday the nxserver service to prevent the high CPU load;  I do not know if this may have interfered with your request of seeing the M- directories contents;

    #37458
    Britgirl
    Keymaster

    Send direct to forum[at]nomachine[dot]com, thanks.

    #37479
    Britgirl
    Keymaster

    Restarting the nxserver would mean you lose the logs. You would need to reproduce the problem again, and send in a new set.

Viewing 5 posts - 1 through 5 (of 5 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.