High CPU usage

Forums / NoMachine for Linux / High CPU usage

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24979
    AvatarBabok
    Participant

    Running  Free version NoMachine Server 6.8.1.1 amd64 on Debian 10 buster, the same version is running the mac client machine on mac (mojave).

    Experiencing a very high CPU usage on server side:

    – 139.4 %CPU nxnode.bin

    – 98.7  %CPU nxcodec.bin

    NoMachine create its own virtual frame buffer on a very high resolution.

    Sometimes had to relaunch the server NoMachine because I couldn’t connect to. I read this bug has been reported before, any news on macOS problem occurring on monitors supporting wide color gamut ?

    Regards.

     

     

    #25006
    Avatarfra81
    Moderator

    Hi Babok,

    can you tell us more about the hardware you have on the server and about the desktop environment (GNOME, KDE…) in use? Besides lowering the screen resolution, you could try to use a lightweight desktop environment, if that’s not the case already (see https://www.nomachine.com/AR07K00676).

    Sometimes had to relaunch the server NoMachine because I couldn’t connect to. I read this bug has been reported before, any news on macOS problem occurring on monitors supporting wide color gamut?

    Can you tell us more about this problem? If you are referring to https://www.nomachine.com/TR10P08920, that should be fixed in version 6.8.

    #25007
    AvatarBabok
    Participant

    server: Intel(R) Atom(TM) CPU  C2750  @ 2.40GHz

    desktop environnement: xfce without lightdm.

    Do you think the cpu’s server cannot handle encoding h264 and could be the reason of high cpu on on a mac client ?

     

    I have the same issue on windows 10 too..

    #25300
    Avatarfra81
    Moderator

    Do you think the cpu’s server cannot handle encoding h264 and could be the reason of high cpu on on a mac client ?

    This is possible if you say that the resolution is very high and given that the CPU is not very powerful. But also note that such CPU usage just means that a bit more than 2 CPU cores are used of the 8 at disposal. To limit CPU usage further, besides reducing the resolution, you can try to lower the frame rate in the Display settings panel.

    #25302
    AvatarBabok
    Participant

    Indeed, pressing I and 1 on top command, irxi mode off help to get a better view.

    So I consider cpu usage is not so high as i thought on 8 cores. Resolution client side is 5120×3200

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.