High GPU Utilization

Forums / NoMachine for Windows / High GPU Utilization

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #28751
    AvatarGatos
    Participant

    Hi

    I’ve been experiencing some problems with the latest NoMachine, lately my computer has started to feel extremely unresponsive.
    I’ve tried updating the drivers (from the latest “Gamer” drivers, to the latest “Studio” drivers)… I’m still getting the same problem, once I connect to the machine it spikes up to 100% and starts giving me artifacts like ghost mice.

    I’ve tried switching from VP8, to h.265, MP4, disabling/enabling GPU acceleration, and change just about every settings on the client side.
    Last night I had issues connecting from two different Windows Client to this Windows client, we weren’t able to connect until we switched to h.265.

    I really don’t know what else I could try.
    this is a fresh install of Windows with basically nothing special installed other the two CAD software and Microsoft office suite.

    Any help would be appreciated, I’ll see if I can roll back to an older version of NoMachine or the drivers, I just though I’d make this post in case somebody is experiencing the same problems, while I look for some kind of solution.

    Gatos.

    #28780
    Avatarfra81
    Moderator

    Hi Gatos,

    the images that you sent couldn’t be attached. Please send them to forum[at]nomachine[dot]com.

    Also logs could be useful (see https://www.nomachine.com/AR10K00697 for server side logs and https://www.nomachine.com/DT10O00163#2 for the client).

    #28779
    AvatarGatos
    Participant

    I didn’t notice that the images were too big 🙂
    I uploaded them to imgur

    View post on imgur.com

    Anyway I don’t actually think I tried enabling MP4 as I just did now and the GPU utilization fell to 0.

    But in that time I’ve just reinstalled windows, NoMachine and the latest drivers, so far the GPU utilization issue seems to be solved, but I can’t stop noticing that the latest version of NoMachine leaves a “ghost mouse” and it still feels noticably slower then it used to (moving windows around lags a behind even on LAN).

    I’ll try to see if I can find an older version of NoMachine to install it and see if there’s a difference there.

    I’m sorry if this a bit messy, but at least I had to point out that GPU utilization could be an issue with the latest Nvidia drivers.

    Gatos.

    #28803
    Avatarfra81
    Moderator

    Thanks for the update.

    The issue with the “ghost mouse” is known, it can happen under some circumstances and it will be fixed probably in the next update. The performance problem is not, so I wonder if this can also be related to the drivers. You may try to disable the ‘Use acceleration for display processing’ option in the Server preferences, Performance tab on the machine where you connect to.

    If in the meanwhile you would like to send the logs, I’d be glad to take a look.

    #28805
    AvatarGatos
    Participant

    Hei

    That’s good to know that the ghost mouse issue is known and being worked on.
    I’ve included the log of the old windows image that was giving me problems, NoMachine got reinstalled, but it still gave me the same high GPU utilization with the new drivers, until I just reinstalled windows for that machine.
    Aas I said it seem to be solved with a clean install of windows with the latest drivers and it works fine (except that ghost mouse), but if it helps solving some unknown issue then I’d gladly upload the logs.

    Just a heads up in nxdx.log there’s about (exactly) 161353 lines of the same error, about every 60ms 🙂
    GenericMode: ERROR! OpenMutex() failed with error [‘5’]

    Attachments:
    1. log.zip
    #28884
    Avatarfra81
    Moderator

    Hi,

    thanks for the feedback and for the last head up. We think we know the reason and we will be addressing that too.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.