Host key verification failed

Forums / NoMachine for Windows / Host key verification failed

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27047
    AvatarDonovan
    Participant

    I have 3 machines running NoMachine. 2 Windows 10 Machines and a Raspberry Pi 4. One machine works great and connects to my Raspberry Pi 4 like a charm. The other machine throws a “Could not connect to the server¬† Error: Host key verification failed” each time I try to connect to either the Raspberry Pi or the working Windows 10 machine. The Working Windows 10 machine can’t connect to the one I am having an issue with either.

    So far, I have uninstalled, rebooted, reinstalled, and rebooted again a few times. I have even deleted the config files in my C:\users\[user]\NoMachine folder as well as the C:\users\[user].nx file in a couple of attempts. I’ve tried the default folders as well as changing the “Connections and recordings”, “Transferred files”, and “Player settings”. Even tried disabling the Windows Firewall and such… No luck.

    All machines are on a local subnet with a 192.168.0.xxx address connected to the same switch. Both Windows machines were installed using the latest version I found on the site (nomachine_6.9.2_1.exe).

    Any suggestions?

    #27103
    AvatarBritgirl
    Keymaster

    It’s not clear whether you’re trying to connect with public key, or mapping ssh port. In any case, the best thing for you to do is send us the logs from the non-working Windows server (the one you are not able to connect to). Follow the instructions here and then send them to forum[at]nomachine[dot]com making sure you reference the title of the topic in the subject of your email.https://www.nomachine.com/DT10O00163#1.

    Then from the client side, either the RPi4 or the working Windows host, send us the .nx folder. https://www.nomachine.com/DT10O00163#2.

    #28010
    AvatarDonovan
    Participant

    Sorry for getting back late on this. I had other issues going on that prevented me from following up.

    I did not end up finding the cause of my problem, but I had to reload my laptop that was experiencing the issues as I found I was also having issues with RDP as well. This led me to dig into the networking on my laptop first, but since I didn’t find the cause, I gave up and just reloaded the laptop….¬† It was long overdue anyhow!

    The reload of the OS (now running Windows 10 Pro version 2004) has got everything back to working as it should and NoMachine is working like a charm!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.