How can I use NX with Lubuntu Desktop (wrong startcommand)

Forums / NoMachine for Linux / How can I use NX with Lubuntu Desktop (wrong startcommand)

Tagged: 

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27863
    Avatarboospy
    Participant

    Hello all,

    I’m running NoMachine Workstation on an Lubuntu 20.04. I can login with virtual deskop, but I look likes Windows98, because it starts not a lubuntusession rather an plain lxqt. So i spend a lot of hours to find out what is the right startcommand for Lubuntu. @the docs i can’t find Lubuntu:
    https://www.nomachine.com/AR07K00676

    So i need the right command in the File: /usr/NX/etc/node.cfg
    DefaultDesktopCommand "/etc/X11/Xsession default"
    I would be very happy about help.

    Best Regards
    Boospy

    #27891
    Avatarkroy
    Contributor

    For LXQt please set:

    DefaultDesktopCommand "/usr/bin/dbus-launch --sh-syntax --exit-with-session /usr/bin/startlxqt"

    #27900
    Avatarboospy
    Participant

    Hello Kroy, very thanks for your answer. This command works,  but unfortunately the same as the original command. What I came up with is that you can then set up the standard Lubuntu Desktop LXQT in the logged-in state per user. This is now a workaround.

    But apparently there has to be another command / option that is used by SDDM. Strange.

Viewing 3 posts - 1 through 3 (of 3 total)

This topic was marked as solved, you can't post.