How do you specify X server DPI for session?

Forums / NoMachine for Windows / How do you specify X server DPI for session?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3467
    Avatarthomase
    Participant

    We are evaluating NoMachine on Red Hat Enterprise 6 and comparing it against OpenText ETX.

    X DPI defaults to 100×100 in a gnome or KDE desktop, and 75×75 in floating mode (e.g. xterm). I can’t figure out how to set this when creating a custom session in the windows client. I see that node.cfg in the server has a setting for this, but it looks like it is controlled by the administrator and can’t be specified by the user per-session.

    Note that this is independent of the Xft.DPI setting for fontconfig.

    #3484
    Avatargraywolf
    Moderator

    Hello.

    The DefaultDPI in node.cfg controls the value of Xft.dpi resource. You cannot specify it per-session, but you  an create a user specific node.cfg: just copy the original node.cfg to a new file called username.node.cfg (specify the user’s name in place of “username”) and edit username.node.cfg according to your needs.

    #3503
    Avatarthomase
    Participant

    I’m only a user and don’t have admin privileges on the server. Therefore I can’t create any files in the /usr/NX/etc directory.

    Anyway, Xft.dpi can be changed on-the-fly (e.g. via the gnome-control-center). The X core font (xfs) DPI setting is something different and I believe it can only be specified when the X server starts. I thought the DPI settings in node.cfg controlled this instead of Xft.dpi. The reason I want to change it is because I run EDA tools, many of which use the legacy X font system instead of Xft/fontconfig. I think some of these tools assume 100 dpi for their default font sizes and don’t look right when the DPI is 75 instead.

    If what you are saying is true, then how do I, as a user, set the X server DPI setting?

    As a side note, I know that xrandr has a ‘–dpi’ switch, supposedly allowing modification of the X server DPI without restarting, but it doesn’t seem to work, at least in NX.

    For reference, my NX session is “floating window” style and starts up with an xterm. I have checked the X server DPI setting with the following command:

    > xdpyinfo | grep dot

    resolution:    75×75 dots per inch

    I can’t figure out a way to change it.

     

     

    #3511
    Avatargraywolf
    Moderator

    You can run the custom session in a “virtual desktop” rather than in “floating window” mode. This would default the DPI to 100.

    #3517
    Avatarthomase
    Participant

    I want to run in “floating window mode” with 100 DPI.

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.