how to access windows in Virtual Box with No Machine

Forums / NoMachine for Linux / how to access windows in Virtual Box with No Machine

Tagged: , ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #690
    bangde
    Participant

    I would like to be able to access my virtual box windows XP .

    Currently i have ubunut installed with virtualbox and i would like to be able to remotley access the XP in virtual box using NoMachine.

    I can log in successfully into the Ubunut manchine that has the virtual box but when i try to log in to XP i can not not.

    I have been told to make a bridge connection in virtual box but it does not work, currently I am using NAT.

    Any help in the righ direction would be greatly appreciated.

    Cheers

    #692
    Dan25
    Participant

    Did you install NoMachine on the Windows (VM) host?

    Do that, then point your client to the Windows IP address for the connection. If you configured the Windows host to have a bridged or a NATted network adapter (so that the IP address of the Windows computer is visible to the other computers on your LAN) this is all you need.

    #717
    bangde
    Participant

    Thank you for the reply.

    I have installed No Machine on windows and the windows host has a nat network but the nat work is giving an Ip address of 10.0.2.15 while my host has an ip address of 162.243.14.121. I have tried the bridge connection but it does not seem to work in my current settings.

    It Might help youwith a bit more info that I am using a cloud based server from digital ocean to run the server and installed virtualbox on that server.

    I am able to access the host with no problem with no machine but accessing the guest virtualbox seems so complicated, I dont knwo knwo what to do or how to fix it.

    #724
    fra81
    Moderator

    It’s very likely that you can’t get an additional public IP for free, since you are on a hosted facility. But you may try to create a tunnel to 162.243.14.121 and from 162.243.14.121 to 10.0.2.15 port 4000.

    ssh -R 4500:localhost:4000 user@162.243.14.121

    It won’t work as fast as a direct connection but better than nothing. Be also sure you disable UDP in the connection setup.

    Otherwise I strongly suggest you ask to the help-desk of the provider offering the hosting service.

Viewing 4 posts - 1 through 4 (of 4 total)

No further information provided by the user for more than 10 days. This topic was marked as closed, you can't post.