How to disable Gnome xsession

Forums / NoMachine Terminal Server Products / How to disable Gnome xsession

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #37755
    plox
    Participant

    Hello,

    I’ve installed one NoMachine Enterprise Terminal Server 7.7.4 and three NoMachine Terminal Server Nodes 7.7.4 in a multi-node-environment with load-balancing disabled and manual-selection enabled, all on RedHat Enterprise.

    All three nodes provides desktops for Gnome, KDE and XFCE. On one of the nodes I want to disable KDE and Gnome.
    I’ve set “AvailableSessionTypes xsession-xfce” in server.cfg and node.cfg as described in https://knowledgebase.nomachine.com/AR07P00989 on one node.
    When I syncronize the node with nxserver --nodeupdate on the server, the server replies that the gnome-sessions is available and I can start the Gnome sessions in the NoMachine client

    NX> 187 Session types available on node: xsession-xfce,xsession-xfce,xsession-gnome-custom-session,xsession-gnome-xorg,xsession-gnome

    I can’t deinstall gnome, because I need some packages which have dependencies on that. How can I disable access to Gnome sessions?

    Regards,

    #37770
    fisherman
    Moderator

    Hello,

    Please set in the server.cfg and node.cfg
    AvailableSessionTypes unix-xsession-default

    and in node.cfg edit DefaultDesktopCommand.
    DefaultDesktopCommand /usr/bin/startxfce4

    #37771
    plox
    Participant

    Hello fisherman,

    sorry, this has not fixed the problem.

    nxserver –nodeupdate node002.mynet.local:4000

    still shows

    NX> 187 Session types available on node: virtualdefault,xsession-xfce,xsession-gnome-custom-session,xsession-gnome-xorg,xsession-gnome

    and I can choose Gnome in the NoMachine client for this node.

     

    #37774
    fisherman
    Moderator

    Please apply requested change in the node.cfg file on the required Terminal Server Node that you want to allow only Xfce4 session.

    #37781
    plox
    Participant

    I’ve changed the node.cfg on the Terminal Server Node as you reccommended. This has no effect, Gnome is still available on this node.

    #37786
    fisherman
    Moderator

    I have just tested and following this, we will limit NoMachine to use ONLY xfce4 on the requested node

    On the node “node002.mynet.local”, please update keys in the node.cfg with:

     AvailableSessionTypes unix-xsession-default
    DefaultDesktopCommand /usr/bin/startxfce4

    then on the Enterprise terminal server execute
    nxserver --nodeupdate node002.mynet.local:4000

    in the nodeupdate command you will see output with
    NX> 187 Session types available on node: unix-xsession-default

    unix-xsession-default listed there means that on that specific node, only DefaultDesktopCommand /usr/bin/startxfce4 session will be started.

    If this still does not work, send us your output of the command --nodelist, output of the command --nodeupdate after editing node.cfg file, and node.cfg file from the requested node.

    Please note this that if you have automatic node selection, sessions will be started possibly on the node where gnome is enabled.

    In case you want to disable automatic node selection, please check following document: DT11R00178 – NoMachine Enterprise Terminal Server – Installation and Configuration Guide.

    #37800
    plox
    Participant

    I’ve found the solution for my environment.

    I need to set in node.cfg of the node:

    DefaultDesktopCommand /usr/bin/startxfce4
    AvailableSessionTypes unix-xsession-default,xsession-xfce

    and in server.cfg of the node

    ConnectPolicy autocreate=1,autoconnect=1,automigrate=1,desktop=1,dialog=1,xsessions=0,udp=1

    xsession was set to 1 in my server.cfg on the node.

     

    Thank you for your help, this topic can be marked as solved.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.