How to get NoMachine to ignore Caps Lock?

Forums / NoMachine for Linux / How to get NoMachine to ignore Caps Lock?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #38502
    HippoMan
    Participant

    I’m running NoMachine 6.17.1-4 under Ubuntu 20.04.4.

    I use NoMachine to connect to NoMachine servers on a Mac and on a Raspberry PI.

    I have Caps Lock remapped on my Ubuntu machine, and it’s also remapped both on the Mac and on the Raspberry PI. When I am directly connected to all of those machines, the Caps Lock remapping works properly. However, when I connect from Ubuntu via NoMachine to either of those other machines, my Caps Lock remapping is ignored, and the Caps Lock key always functions in its default manner on those machines.

    In other words, even though Caps Lock is remapped on my client Ubuntu machine and on both of those server machines, NoMachine ignores that remapping and always forces Caps Lock to function in a non-remapped manner.

    It’s important to me to totally and completely disable Caps Lock functionality, which is why I have remapped the Caps Lock key on all of those machines. Is there any way to tell NoMachine to stop honoring the Caps Lock key and to use my remappings? Or better yet, can I tell NoMachine to completely disable the Caps Lock key when I am connecting via NoMachine to these other machines?

    Thank you very much for any suggestions.

    #38507
    Britgirl
    Keymaster

    Can you tell us how you did the remapping on all the machines?

    When I am directly connected to all of those machines

    What do you mean by “directly connected”?

    What version of NoMachine is on the two computers, the Mac and Raspberry machines?

    #38520
    HippoMan
    Participant

    Thank you for your reply.

    By “directly connected”, I mean “when using the keyboard on those machines, and without NoMachine being in use”.

    The Raspberry PI machine has the same version of NoMachine as my Linux box: 6.17.1-4

    The Mac is running version 7.9.2

    I disable Caps Lock on both the Linux box and the Raspberry PI as follows:  /usr/bin/xmodmap -e ‘keycode 66=Shift_L’ . This just maps it to the normal Left-Shift key. That works fine on both of those machines when I am using the keyboard. But the mapping gets ignored when I’m connected via NoMachine, and it forces the full Caps-Lock functionality on the Raspberry PI.

    On the Mac, I use the Karbiner-Elements.app utility to map CapsLock to Left-Shift. Again, this works fine when I’m using the Mac’s keyboard, but it gets ignored when I’m connected via NoMachine, and it forces the full Caps-Lock functionality on the Mac.

    I don’t have this problem when using [removed] to connect to the Mac and to the Raspberry PI from my Linux box. My remapping of CapsLock works fine when connecting in that way to each machine. This Caps-Lock problem seems to be related to NoMachine itself.

    Also, I have just now upgraded my Linux box and my Raspberry PI both to use NoMachine 7.9.2-1 .  This Caps-Lock problem remains the same.

     

    #38563
    HippoMan
    Participant

    Correction: when I use /usr/bin/xmodmap -e ‘keycode 66=Shift_L’ on the Raspberry PI, my Caps Lock mapping indeed functions properly when I’m connecting to that host via NoMachine.  I had incorrectly tested this in the past.

    However, I still have the problem with the Caps Lock key mapping being properly recognized on the Mac, as I reported above.

     

    #38656
    Britgirl
    Keymaster

    We’ve been able to reproduce the same behaviour with Karabiner and are investigating further.

    Edited: July 8th. Please see this topic for our response on Karabiner.

    Using Karabiner on macOS

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.