How to make NoMachine update target computer IPs?

Forums / General Discussions / How to make NoMachine update target computer IPs?

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #38591
    blandy
    Participant

    I have computers on a home network that I NoMachine into. When the computers sleep and wake, or when a new device appears on the network, they get new IPs. NoMachine doesn’t seem to update the IP for the machine, so it fails to connect when I first try. I have to then open the NoMachine server on the target computer, find the IP (or generally, find the local IP of the machine), and re-enter it into NoMachine for that target computer.

    How do I remove this manual process (other than giving my computers static IPs on my home network, which isn’t an option for me)?

    #38629
    kroy
    Contributor

    Hi

    You don’t have to change IP manually. It will change automatically after few seconds. Problem is that it looks that you already entered IP manually and it’s saved permanently in connection file now. You can remove that change with editing .nxs (probably last file in the: ~/.nx/cache/) on client side. Find line with key “Server host” and delete IP value like here:

    <option key=”Server host” value=”” />

    #38636
    blandy
    Participant

    thank you. Where does that file live on windows?

    #38646
    kroy
    Contributor

    Also in the home directory – C:\Users\your_username\.nx

    #38671
    blandy
    Participant

    Hi kroy, there is no folder like that on my machine (Windows 7) – there is a C:\Users\nx directory, but none of the sub directories have a cache folder

    #38680
    kroy
    Contributor

    What is your username for the computer you are accessing? This “username” is what you should write here: C:\Users\HERE\.nx\cache

    Folder “.nx” is hidden, you can set File browser to show hidden items or just paste C:\Users\PASTE-HERE-USERNAME\.nx\cache path in navigation bar in the File browser.

    #38703
    blandy
    Participant

    Ah ok, I was thrown off because some dot folders were showing up, but not the .nx one, I’ve removed the cached XML lines now.

    So now NoMachine has found the computer’s public IP automatically, but not the local one. So I had to go in and edit it manually again. How do I get NoMachine to use the local IP for discovery?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.