How to setup server on Centos

Forums / NoMachine for Linux / How to setup server on Centos

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #180
    Avatarjmi
    Participant

    I just downloaded and installed NoMachine for Linux 64-bit. However, I was not able to start the server (nxserver) as out-of-box.
    when I issued the following command:
    /usr/NX/bin/nxserver –start
    I got the output as
    NX> 161 Enabled service: nxserver.
    When I issued the command:
    /usr/NX/bin/nxserver –status
    I got the output as
    NX> 161 Enabled service: nxserver.
    NX> 162 Disabled service: nxd.

    Basically, I couldn’t start nxd, even when issuing
    /usr/NX/bin/nxserver –start nxd

    How can I start nxd? Is it required for the server?

    Any help is greatly appreciated.

    Jason

    • This topic was modified 7 years, 2 months ago by AvatarJohn Watts. Reason: spelling for process nxd
    #194
    Avatarjwcpc
    Participant

    Jason,

    You are using the base NoMachine for Linux free product? What Linux distribution are you using to host the NoMachine install? e.g. Red Hat, etc.

    Can you still make a connection to your NoMachine installation even with this error message?

    /John

    #197
    Avatarjwcpc
    Participant

    Jason,

    Sorry I meant what specific version of Centos are you running?

    /John

    #331
    Avatarlshelton65gt
    Participant

    I’m going to piggy back on to this one because I have the same issue.

    The machine that NX is installed on is CentOS 5.8 32-bit.

    Thanks
    Lewis

    #356
    Avatarfordboy0
    Participant

    `Hi Lewis,

    Edit /etc/selinux/config and change ‘SELINUX=enforcing’ to ‘SELINUX=disabled’ and reboot.

    #370
    Avatarlshelton65gt
    Participant

    This was done previously. Any other suggestions?

    Thanks!
    Lewis

    #387
    Avatarjmi
    Participant

    I am still trying to get the latest non-enterprise version 4.0.360 for 64-bit to work for my centos as server and Windows 7 as client. No success so far.
    What I’ve tried are as below:

    Right out-of-box for both server and client with NX protocol, connection timed out. If I connect client and the server on the same centos machine, it works.
    Somehow, I think that the NX protocol on port 4000 does not work for me if the client is on a Windows 7.

    When switching to SSH protocol by adding SSH to ClientConnectionMethods in server.cfg, I can get the login, but then got “Error is: SSH connections are not supported on this server.”. By reading the doc, it appeared to me that SSH protocol is not supported in the non-enterprise version.

    Any guidance on what to try the next…

    Thanks,
    Jason

    #389
    Avatarsil04
    Keymaster

    If I connect client and the server on the same centos machine, it works.

    can be that a firewall rule is blocking port 4000?

    #401
    Avatarlshelton65gt
    Participant

    In my case, the firewall is disabled.

    Lewis

    #415
    Avatarjmi
    Participant

    My firewall on centos where NX server is running is also disabled. Could be other network setting blocking me from access it?
    On another machine in my office, ‘telnet x.x.x.x 22’ connects where x.x.x.x is the IP for the centos. But ‘telnet x.x.x.x 4000’ doesn’t connect.

    Is there a way to enable SSH (port 22) protocol on the server with my non-enterprise version 4.0.360?

    Jason

    #416
    Avatartitan
    Participant

    Hi Jason,

    can you please tell me what you see in /usr/NX/var/log/nxd.log on the server?

    #418
    Avatarjmi
    Participant

    Hi titan,

    I just stopped nxd, deleted nxd.log and then restarted nxd so that you can have a clean log file to take a look at. I also tried to connect to it from my Windows 7 client with no success. Below is all in the nxd.log.

    Info: Server started with pid 17603 on Sat Nov 2 14:51:28 2013.
    Info: Listening for connections on any interface on port 4000.
    Info: Accepting connections from any host with encryption enabled.

    It doesn’t look like it received any connection request. On my NX client window, it displayed:
    Could not connect to the server.
    Error is 138: Connection timed out

    If we cannot resolve this due to network setting for port 4000, can we possibly enable SSH port 22 on the NX server? Again, I’m using the non-enterprise version 4.0.360 for 64-bit.

    Thanks for your help!
    Jason

    #424
    Avatartitan
    Participant

    Jason,

    open a console and run:

    > ps auxwww| grep nxd

    You should see nxd running with pid 17603. Can you see it?

    AFAIR you said that you can connect to nxd when running the client on the same machine. It seems to me a trivial firewall problem, that is the connection on port 4000 is blocked before reaching nxd. It can be a security feature on your machine blocking connections to “unknown” services. The installation script adds all the required rules for SELinux and AppArmor. You disabled SELinux and this didn’t work either… I don’t think changing port will help, but…

    Install netcat (nc) and run:

    > nc -l 4012

    Or some other port. Then on another machine:

    > telnet server_machine 4012

    Can you connect to this other port?

    There is not much more that I can say. What I can suggest is:

    – Tunnel the connection to that machine by ssh. See this post on how to do it:

    https://www.nomachine.com/forums/forums/topic/unable-to-connect#post-228

    – Install the Workstation evaluation. In the meanwhile we’ll investigate if there are similar reports from other users

    #447
    Avatarjmi
    Participant

    Hi Titan,

    Thanks for the tip of tunneling. I installed openssh on my windows and used it to tunnel the way you described. My NX client can now connect to the NX server.

    Great help! Thanks again.

    Jason

    #463
    Avatarsil04
    Keymaster

    Jason,

    can you please provide output of this command?

    /sbin/iptables -L

    It’s for checking if iptables are still on for some reasons.

Viewing 15 posts - 1 through 15 (of 17 total)

This topic was marked as solved, you can't post.