How to solve slow response connecting to headless (no monitor) Raspberry Pi

Forums / NoMachine for Raspberry Pi / How to solve slow response connecting to headless (no monitor) Raspberry Pi

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #36199
    xevilmax
    Participant

    Hi,

    It’s not a question, it’s directly a solution.

    I’m setting up new Arm64 RaspiOs (beta) with latest 5.10.y-78 kernel.

    https://downloads.raspberrypi.org/raspios_arm64/images/

    Testing on RPI4 and RPI3B+

     

    While monitor is connected and i boot system, all works fine (at least with 128mb or more of GPU).

    But when i boot without monitor attached remote GUI connection is almost unusable.

    Tried different workarounds:

    • Setting up: xserver-xorg-video-dummy (not good if monitor sometimes is attached sometimes not)
    • sudo service lightdm stop
      sudo /usr/NX/bin/nxserver –restart

    But here is my top solution:

    #Open configs
    sudo nano /boot/config.txt
    #Disable Hardware acceleration (may be useful only if you are sure to have always monitor attached)

    #Enable DRM VC4 V3D driver
    #dtoverlay=vc4-kms-v3d
    #max_framebuffers=2

    #Save and exit
    sudo reboot now

     

    After this all works perfectly with or without monitor attached

    Also you may want to set defaut screen size in config.txt like:

    # uncomment to force a console size. By default it will be display’s size minus
    # overscan.
    framebuffer_width=1440
    framebuffer_height=900

     

    Hope it will be useful to someone in future.

    #36435
    Britgirl
    Keymaster

    Thanks for submitting this to our forums! Other RPi users could find it extremely useful 🙂

Viewing 2 posts - 1 through 2 (of 2 total)

This topic was marked as solved, you can't post.