How to turn off scaling/pixel doubling when using the client on a Retina Mac?

Forums / NoMachine for Mac / How to turn off scaling/pixel doubling when using the client on a Retina Mac?

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29643
    Avataranyfoo
    Participant

    The macOS nomachine client forcibly does scaling/pixel doubling. This effectively means that I cannot connect to any HiDPI desktop without lowering the resolution, despite both client host and remote host supporting high resolutions.

    I know that thisĀ can work, because if I use e.g. ScreenResX to turn off UI scaling entirely on the client Mac, the nomachine client stops being scaled, too, and the result looks very good. However, turning off UI scaling on a Retina Mac globally is not a good option, as everything is very tiny then.

    So it seems that it should be possible to support this just by passing the right flag or something internally. I however have tried everything I can think of, with no result. Is there maybe a hidden command line flag or something to tell the nomachine client to just stop scaling? I wouldn’t even mind if that stops scaling the client’s UI, I can live with that over losing the resolution.

    #29705
    AvatarTor
    Contributor

    Do you maybe mean the “Open in Low Resolution” mode available in bundle’s info? Right click bundle name, select “Get Info” and check the box.

    #29712
    Avataranyfoo
    Participant

    No, that does sort of the opposite. Now, the NoMachine client’s UI elements are sort of blurry because they are not drawn in HiDPI anymore, but the forced scaling of the pixels of the remote desktop stays the same.

    So, what I would need would be something like a “Open in forced High Resolution” checkbox, which would make the NoMachine client’s UI elements tiny, but display the remote with 1:1 pixel ratio, but unfortunately that does not exist. (I know that it would work because if I use ScreenResX to effectively force Retina scaling off systemwide, everything on my Mac gets really tiny, but the remote desktop is displayed correctly).

    So it seems the only way is for the nomachine client to just not scale, or pass the right flag to the system to stop scaling. I thought this should be really simple code-wise, but now I see that nxplayer is linked against Carbon, and maybe there is just no way to tell the (very deprecated) Carbon framework to do so?

    But it’s worth noting that the client’s UI appears very sharp, so Carbon does at least seem to have support to display high resolution images.

    #29713
    Avataranyfoo
    Participant

    This is a bit frustrating, because this one technically tiny (but effectively crucial) thing is preventing me from fully using nomachine. Everything else works fantastically for me, much better than any other remote desktop solution I have tried so far (but all the others support HiDPI).

    #29785
    AvatarTor
    Contributor

    You probably need this, currently in our short/mid-term roadmap:

    https://www.nomachine.com/FR02M02864

    #29792
    Avataranyfoo
    Participant

    Thanks, it looks like that might indeed fix it.

    Retina Macs have pretty much become the norm (the first Retina MacBook came out in 2012, the first 5k iMac in 2014), so this will really make a difference on being able to use NoMachine with Macs.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.