How to window scale

Forums / NoMachine for Linux / How to window scale

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #39721
    boda
    Participant

    Hello

    Server – Ubuntu 22.04, client – Ubuntu 20.04, ‘nomachine_7.10.1_1_amd64.deb’ both
    Connecting is ok, but there is no option to set client window to fixed size?

    For example: server has 1552×942, so it may fit well in client screen 1920×1200, but I only can resize client window by mouse move, where is no such settings described in https://kb.nomachine.com/AR02M00835

     

     

    #39774
    Britgirl
    Keymaster

    The player window, once you’ve resized it to the size you want, should keep the same dimensions next time you start that session (using the same .nxs file).

    Can you give some more details about what you are trying to achieve? You say “but I only can resize client window by mouse move,” what do you mean exactly?

    #39800
    boda
    Participant

    I want to display server screen on client pixel to pixel – i.e. windows must resize to 1552×942 (content area)
    I do not want resize manually to what size – it is now easy )
    In “pixel to pixel” window, for example, fonts will be displayed clearly and sharply, without interpolation or such effects

     

    #39804
    Britgirl
    Keymaster

    You can set the “Session window geometry” key in the .nxs session file to a specific client screen resolution. So for example your screen resolution is 1920×1200:

    <option key=”Session window geometry” value=”0, 0, 1920, 1200″ />

    Also set these keys to viewport:

    <option key=”Physical desktop resize mode” value=”viewport” />
    <option key=”Session resize mode” value=”viewport” />
    <option key=”Virtual desktop resize mode” value=”viewport” />

    So if the remote display resolution is smaller than the client window, the client window will be resized to show the exact remote display resolution; so will automatically match the exact size which is needed to show full remote server display. If remote display has bigger resolution, we will just show scroll bars, but still, remote display will be not be scaled.

    #39809
    boda
    Participant

    Thanks for answer

    I tried to connect to another Ubuntu 20.04 machine, and can select option not to resize (as on screenshot)

    Maybe previously i skipped that window

    And a little bug – in kubuntu left mouse click on tray NoMachine icon not raises NoMachine main window
    only need to right click and select “show main windows”

    #39815
    Britgirl
    Keymaster

    and a little bug – in kubuntu left mouse click on tray NoMachine icon not raises NoMachine main window
    only need to right click and select “show main windows”

    Thanks for reporting, we’ll get that checked out.

    I tried to connect to another Ubuntu 20.04 machine, and can select option not to resize (as on screenshot)

    You probably selected to not show this dialog anymore. Welcome panels appearing when the connection to the desktop has been established can be restored by checking the “Reset saved preferences and password”  box while editing the corresponding connection settings.

    These options in the welcome panel are always available on the bottom on the menu. In your case, it is the most left icon (https://kb.nomachine.com/DT10R00168?#5). When multiple monitors are present, it’s the penultimate on the left.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.