Http server doesn’t start

Forums / NoMachine for Linux / Http server doesn’t start

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #26385
    AvatarericT
    Participant

    Hi,

    I’m trying to log to an NX machine via Web, but it doesn’t work. I downloaded the free version, I think (“download” button, vers. 6.9.2 on home page).

    It seems this version doesn’t allow http connections, though (/etc/NX/nxserver –start nxhtd answers : NX> 500 ERROR: Support for HTTP server is not permitted on this server.)

    Is there a way for me to test a version with web access authorized ?

    Thanks

    ET

    #26404
    AvatarericT
    Participant

    Hi,

    I finally found trial versions and tested the cloud version… but it didn’t work :

    I installed cloud version on a PC (pc1), then I installed free version on another one (pc2). I connected to web interface on cloud machine (pc1), but when I try to add the other machine (pc2), I got errors, whichever way I try :

    Connection with nx protocol : I got an error message : Cannot add server pc1:4000. The remote server type NoMachine cannot be be a server of server type NoMachine cloud server evaluation .

    Connection with ssh only : (NoMachine not installed on machine box checked) : after login informations given, message pc2 is being configured, progress picture running a long time, and error message : cannot add server pc2. NoMachine cannot access any X server on the remote host

    For the record : I connect with ssh -Y from pc1 to pc2, and start a graphical app without any issue.

    Both pc1 et pc2 are ubuntu-mate 18.04

    If you could explain what happens…

    One more question : The purpose for this test are : give remote access to 24 PC in a room to students. Maybe I’m not using the right versions.

    I was able to connect from web interface from pc1 to pc1, connecting to the interface with root account, but when I connect to the web interface with normal user interface, I can’t see pc1 in the list.

    Thanks for your help, and sorry for the amount of questions (maybe I should modify the title of my post or create (an)other(s) )

    ET

    #26422
    AvatarBritgirl
    Keymaster

    Cannot add server pc1:4000. The remote server type NoMachine cannot be be a server of server type NoMachine cloud server evaluation .

    The free version cannot be added to Cloud Server. Choose any of the Enterprise-oriented products. If you are looking for the enterprise version of the free NoMachine package, you should download and install Enterprise Desktop.

    The second error is not so simple. You need to have configured the foreign server (so there is no NoMachine software installed) so that its physical desktop allows remote access, and the cookie for this access has to be in the default xauthority file of the user you are trying to use to add this server.

    I would suggest you start again, and follow this tutorial: https://www.nomachine.com/adding-servers-to-nomachine-cloud-server-via-the-user-interface for how to add servers via the GUI.

    For advanced configuration and set-up, please refer to

    3.5. Federating ‘Foreign servers’ under a Cloud Server
    https://www.nomachine.com/DT02O00123#3.5

    and

    How to use NoMachine v. 6 to access legacy unix-based systems (foreign servers)
    https://www.nomachine.com/AR11O00943

    Let us know how you get on.

    #26462
    AvatarericT
    Participant

    Thanks for your quick and precise answers

    I managed connect servers to cloud using Enterprise desktop

    For foreign servers, though, it didn’t work. I red the docs in your links. Everything seems alright (including .xauthority file). I can connect with ssh -Y and launch a graphical app.

    But when I tried to add the server with cli (nxserver –serveradd pc1 –label pc1 –foreign), I got this message :

    NX> 500 ERROR: Cannot add server: pc1. NoMachine cannot access any X server on the remote host.

    I tried with hostname and FQDN (with domain), I had the same result. I tried to make xorg listening to TCP (netstat shows it is on port 6000), added xhost + to root .bashrc, nothing worked

    If you had some more clues to help…

    ET

    Maybe I missed something

    #26486
    Avatarkroy
    Contributor

    Possible that there is problem with wrong cookie. Execute command on that foreign host:

    xauth list :0

    It should show similar output:

    ubuntu-mate-18/unix:0  MIT-MAGIC-COOKIE-1  035d99d99c612bc76350167aeeb7be63

    Then go to cloud-server machine and add IP foreign machine to /etc/hosts and set hostname from xauth (in this example: “ubuntu-mate-18”). Now add server again, using that hostname (or IP).

    nxserver --serveradd ubuntu-mate-18 --label pc1 --foreign

    #26499
    AvatarericT
    Participant

    xauth list :0 returns nothing

    xauth -ni list returns :

    pc2/unix:10  MIT-MAGIC-COOKIE-1  c3c06ce5a660a0cf13080ddefb6ed811

    I don’t know why the display is set to :10

    I created a new magic cookie, with :

    xauth add pc2/unix:0  MIT-MAGIC-COOKIE-1  c3c06ce5a660a0cf13080ddefb6ed811

    Now xauth list :0 returns

    pc2/unix:0  MIT-MAGIC-COOKIE-1  c3c06ce5a660a0cf13080ddefb6ed811

    But… nothing changes : still the same error (I added a line for this PC in /etc/hosts too, but I don’t think it’s usefull : I can ssh to the host)

     

    #26593
    Avatarkroy
    Contributor

    It’s important that X server is up and running on the Foreign server host. What kind of session is running there? Is it Xorg, XWayland, or maybe Xvfb? What application is inside the session? Can you put here /usr/NX/var/log/nxerror.log output?

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.