I can connect Android to Linux but not Linux to Linux

Forums / NoMachine for Linux / I can connect Android to Linux but not Linux to Linux

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42065
    erik_sk
    Participant

    There was a time when I could connect from my Linux laptop to my Linux desktop. But a while back it started doing this thing where it would connect for a second and the disconnect. I have tried turning off “Use hardware encoding” as suggested in another topic. I have tried setting a rule in my firewall to allow port 4000 on both machines, and then disabled the firewall all together. This is true for either Laptop to Desktop or the reverse.

    The strange part is that I can connect without issue to either machine from both my Android phone and tablet (both Samsung, app version is 6.1.9) under any configuration on the desktop re hardware encoding or firewall setup.

    Some basic info about the Desktop setup:

    NoMachine version: 8.2.3

    OS: Manjaro Linux x86_64
    Kernel: 6.1.0-1-MANJARO (recently updated to this kernel, but the problem was present prior to update)
    Resolution: 1600×900, 1366×768
    DE: Xfce 4.18
    WM: Xfwm4
    CPU: 11th Gen Intel i5-11400 (12) @ 4.400GHz
    GPU: NVIDIA GeForce RTX 3060 Lite Hash Rate

    Some basic info about the Laptop setup:

    NoMachine version: 8.2.3

    OS: Manjaro Linux x86_64
    Host: ASUS TUF Gaming F15
    Kernel: 5.15.81-1-MANJARO
    Resolution: 1920×1080
    DE: Xfce 4.18
    WM: Xfwm4
    CPU: 11th Gen Intel i5-11400H (12) @ 2.700GHz
    GPU: Intel TigerLake-H GT1 [UHD Graphics]
    GPU: NVIDIA GeForce RTX 3050 Mobile

     

    #42073
    Bilbotine
    Participant

    Hi Erik,

    The logs would be helpful to understand what goes wrong.

    Can you please send them by email to forum[at]nomachine[dot]com, making sure to reference the topic as the subject of the email?

    Thank you!

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.