I can no longer maximize display to portrait monitor

Forums / NoMachine for Windows / I can no longer maximize display to portrait monitor

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #13755
    mdear
    Participant

    I am running player 5.1.26 with the free server 5.1.62.  The server is running on a RHEL6 VM on an Esxi5 hypervisor.

    Up to last week, I was able to maximize my NoMachine session across multiply sized monitors.

    Now, when I select NoMachine menu->Display->Resize remote screen I get black bars either to the left/right or above/below my screen as the resolutions required by my monitors (1080×1920 and 1920×1080) no longer appear to be supported.  This has recently stopped working and I’m looking to fix this.

    I have been playing with xrandr for several days now and all attempts to resize my display / add new resolutions have met with limited success.  I was able to manually force a 1080×1920 mode but it is actually a little too big for my monitor and scrollbars are appearing which I don’t want.  I did not see the scrollbars last week when maximizing onto this monitor.

    However, I just cannot get xrandr to set the required resolution to get my portrait monitor working so my workflow is being seriously impacted.

    My video memory on the VM is sized appropriately (oversized, actually), so is not contributing to the problem.

    I am connecting via my Windows 10 laptop.

    #13767
    graywolf
    Moderator

    I’m suspecting the server had gdm turned off. In that case NoMachine launches its own virtual display that is able to resize to any resolution.

    So I suggest try to turn off gdm (service gdm stop) and restart NoMachine (/usr/NX/bin/nxserver --restart).

    #13771
    mdear
    Participant

    It appears the “service gdm stop” command is not available on Red Hat Enterprise Linux 6, please advise, thanks.

    #13785
    graywolf
    Moderator

    It appears the “service gdm stop” command is not available on Red Hat Enterprise Linux 6, please advise, thanks.

    You’re right, sorry. Try this: init 3
    to switch to runlevel 3.

    Edit /etc/inittab if you want to make runlevel 3 the default.

    #13793
    mdear
    Participant

    Yep, that did the trick.  It works now, many thanks, graywolf !

Viewing 5 posts - 1 through 5 (of 5 total)

This topic was marked as solved, you can't post.