I hear my voice in the speakers

Forums / NoMachine for Windows / I hear my voice in the speakers

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #28641
    Avatarykiselev
    Participant

    Client into Ubuntu 20, Server – Win2019. I allow to use mic in settings. When I talk via zoom or skype I hear my voice from speakers. What shall I do to prevent this?

    #28747
    Avatarwitek
    Participant

    Hi,

    What is your default input and output audio device on Windows? You probably have “NoMachine Microphone Adapter” set as a default output device. In this case NoMachine records audio stream from this device and transmits it to the other side, so that is why you can hear your voice on the client side.

    If “NoMachine Microphone Adapter” is your only available option for output device you can try to add “NoMachine Audio Adapter”. Please run the following command as administrator using correct path of NoMachine executables, for example:

    "C:\Program Files (x86)\NoMachine\bin\nxservice64.exe" --deviceadd --inffile "C:\Program Files (x86)\NoMachine\bin\drivers\nxaudio\amd64\nxaudio.inf" --hardwareid *NXVAC

    After that, set “NoMachine Audio Adapter” as the default output and “NoMachine Microphone Adapter” as the default input in Windows sound settings. If you are doing it in a NoMachine session you can just use the command below to respawn nxnode process which will start audio service with new selected default device:

    taskkill /f /fi "IMAGENAME eq nxnode.bin" /fi "USERNAME eq SYSTEM"

    #28767
    Avatarykiselev
    Participant

    Thanks, it works

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.