Ignored ALT key first time pressed

Forums / NoMachine for Windows / Ignored ALT key first time pressed

Tagged: 

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #9234
    Avatarewwhite
    Participant

    I have a number of ALT related keyboard mappings in Emacs on Linux that I use quite frequently. There is an already knows open issue that has been filed for this problem:

    https://www.nomachine.com/TR08M05960

    It is currently marked as ‘minor’ but this is more along the lines of a major irritation for me as I’m constantly swapping between windows and NX session and getting bitten by this bug.  Effectively I end up inserting random characters into the current buffer I’m working on, some of which I end up not noticing and then get compile errors due to these errant keystrokes.

    I’d like to request that this be updated to ‘normal’ at least because I fear that anything in the ‘minor’ state is probably not going to get any attention for quite a long while.

    My guess is that many users are effected but don’t know it’s this bug causing these strange random effects where ALT is ignored the first time it is used after switching to the NX session.

    #9253
    AvatarBritgirl
    Keymaster

    The fix for that is actually planned for the next release, so currently going through QA.

    #9342
    Avatarwernermaes
    Participant

    Same problem here.

    Looking forward to solution.

    Kind regards

    Werner Maes

    #9561
    Avatarewwhite
    Participant

    This didn’t seem to make it into the 5.0.58 release.  Brit, can you give an update on this, and preferably update the priority to ‘normal’.

    #9614
    AvatarTor
    Contributor

    Hello.
    Our recent release was mainly focused on mobile platforms, so some fixes didn’t go through all required testing and were delayed to the next release.
    Nevertheless if you want to test our version including this fix, just contact us on forum[at]nomachine[dot]com.

    #9682
    Avatarewwhite
    Participant

    Thanks! Yes, I’d be willing to beta test a fix for this.  I just set a note to the address you mentioned.

    #9854
    Avatarewwhite
    Participant

    Just tested the TR08M05960 patch you sent this morning. Unfortunately, I’m not able to connect to my NX session with the patched binary so haven’t been able to test if this is fixed. I get the following error message when I try to connect with the patched binary with existing profiles.

    Could not connect to the server.

    Error is 22: Invalid argument

    I also triead creating a ‘new’ profile but I got the same error message.

    I’ve attached the session logfile.

    #9857
    AvatarBritgirl
    Keymaster

    Send the logs directly. They may have been too big to upload here.

    #9889
    Avatarewwhite
    Participant

    Hi Brit, I found the problem – I was still on 5.0.43 and didn’t realize there had been an update to 5.0.63 so was applying the patch to the wrong release.

    I did some initial testing, trying ALT and non-alt key combinations after Atl-tab transition to NX window and so far I haven’t seen any issue.  I’ll continue using the release today and update this topic if I do see any problems.

    Thank you!

Viewing 9 posts - 1 through 9 (of 9 total)

This topic was marked as solved, you can't post.