Impossible to enter more than 1 symbol when using Enterprise Client on Kubuntu/Wayland

Forums / NoMachine for Linux / Impossible to enter more than 1 symbol when using Enterprise Client on Kubuntu/Wayland

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #35110
    eugenez
    Participant

    Hello.

    There is a problem when working from a machine with Wayland session running:

    local side: Kubuntu 21.04, Wayland session, nomachine-enterprise-client 7.6.2-6

    remote side 1: Arch Linux, NoMachine 7.0.211-1

    remote side 2: Windows 10, NoMachine 7.6.2

    When connecting to any remote server, you can enter only 1 character, after that the keyboard does not respond to pressing. The mouse works normally.

    If you start the X session locally (local side: Kubuntu 21.04, X session, nomachine-enterprise-client 7.6.2-6), the keyboard works as it should.

    Is there a solution to the problem?

    #35134
    Tor
    Contributor

    Hi. First time I hear something like this, we daily use Kubuntu 21.04 and unfortunately we can’t reproduce the issue, so we’d need your help to verify what is happening. First of all would you please start an X11 app (Xterm, for example) and check if you reproduce the same behaviour?

    #35143
    Tor
    Contributor

    Hello. We’ve found that KWin has issues with passive keyboard grabbing on Wayland. If you can confirm that the problem occurs when grabbing is enabled, then you can try to start the client with the following command:

    /usr/NX/bin/nxplayer --activegrab

    #35171
    eugenez
    Participant

    [code]/usr/NX/bin/nxplayer –activegrab[/code]

    If run client as you suggested, with –activegrab option, the keyboard in the player window works normally. Thank you.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.