Incorrect distance when moving mouse cursor with left button pressed

Forums / NoMachine for Mac / Incorrect distance when moving mouse cursor with left button pressed

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #39328
    akorzy
    Participant

    Hello, I’m observing bizarre behavior when moving the mouse cursor with the left button pressed. When the button is pressed, the distance that the mouse cursor moves is much smaller than the distance the user moves the mouse. Then, when the user releases the button, the mouse cursor suddenly teleports to a distant location in the direction the cursor was previously moved.

    This behavior makes it difficult to drag and drop items on the screen. It also makes it difficult to select text on the screen.

    The behavior occasionally goes away, but most of the time it is present.

    The behavior started after updating NoMachine to version 7.x.

     

    Host: MacOS Monterey 12.4, NoMachine Enterprise Desktop Subscription 7.10.1

    Client: Windows 10, NoMachine Enterprise Client 7.10.2

    Connecting to a physical display.

     

    Best regards,

    Aleksander

    #39424
    Britgirl
    Keymaster

    Does this happen in all applications that you are using in the remote desktop session or just one application (name of program?)?

    #39440
    akorzy
    Participant

    Dear Britgirl,

    I’ve noticed that problem occurs with all applications I’ve tested: Notes, TextEdit and Brave Browser.

    I’ve also verified that the problem occurs the same way with the following combinations:

    viewport + windowed mode

    viewport + fullscreen

    scaled + windowed mode

    scaled + fullscreen

    I’ve noticed that the problem goes away if I use the mouse to switch to another application and switch back to the application where I want to select something. Then if I start typing in that application, the mouse cursor disappears and when I start moving the mouse again, the mouse cursor appears again and the odd selection behavior comes back again.

    Best regards,

    Aleksander KorzyƄski

     

     

    #40591
    Britgirl
    Keymaster

    Updating to version 8.1.2 solves this issue.

Viewing 4 posts - 1 through 4 (of 4 total)

This topic was marked as closed, you can't post.