Incorrect keyboard mapping (‘)

Forums / NoMachine for Mobile / Incorrect keyboard mapping (‘)

Tagged: 

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #27207
    zzaiasdf
    Participant

    I am using NoMachine on Ipad OS. But when I tap ” ‘  “. I got v or V on my mac.

    By the way. We’re dying for some features for iPad os such as scroll, switch desktop (by three fingers swiping on Mac), etc.

    #27346
    Tor
    Contributor

    NoMachine maps virtual keyboard symbols to symbols available in the remote keyboard layout. Some symbols like the opening or closing quotation marks are typographical and not available in the layout, so the app can’t tell the server what is the correct way to type them.
    In the extended symbols you see when tapping and holding the apostrophe key, the second and the fourth symbols (attached image) will be correctly sent to the server.

    We’re dying for some features for iPad os such as scroll, switch desktop (by three fingers swiping on Mac), etc.

    Do you mean scrolling with mouse and trackpad? As for the gestures, we’ll carefully evaluate what we can do without interfering with app gestures.

    #27396
    zzaiasdf
    Participant

    I’m sorry I didn’t make it very clear. Actually I mean ” ‘ ” on keyboard. Whether it is magic keyboard in use or Logic Bluetooth keyboard(k380), I tap ‘ on keyboard and I get V or B (usually B) on my Mac. And got b or v (usually b) when tapping “.

    When using virtual keyboard, ” worked but still got B when tapping ‘.

    This is also a problem when connecting to ubuntu.

    #27404
    Tor
    Contributor

    Thank you for the additional information. Can you please confirm your keyboard language on iPad and your layout on macOS?

    #27405
    zzaiasdf
    Participant

    The language of my iPad keyboard is English(US). I only use this language when using NoMachine because simplify Chinese language doesn’t worked at all. And I won’t use simplify Chinese language because I can switch input method of my Mac if I want to input Chinese.

    I have no idea how to check my layout on macOS.

    Did you mean keyboard layout? The keyboard connected to my Mac is fully worked.

    In addition, the type of the keyboard is Vortexgear TypeQ104.

    #27426
    Tor
    Contributor

    Thanks. This looks to be an old problem popped out again after some OS changes. Please try this: enter Settings > General > Keyboard and turn off Smart Punctuation. Let me know if this fixes it.

    #27446
    zzaiasdf
    Participant

    It worked!  Thanks!

    At one point I thought maybe turning off Smart Punctuation of my Mac may fixes it. But I forget there is a same setting on iPad.

Viewing 7 posts - 1 through 7 (of 7 total)

This topic was marked as solved, you can't post.