Initially connection refused 111

Forums / NoMachine for Linux / Initially connection refused 111

Tagged: ,

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #14784
    Avatardkebler
    Participant

    Brand new installs of NoMachine on rpi3 running Ubuntu Mate 16.04 and on my Intel box running Mint 18

    I’ve got everything set up to start a session on a headless Raspberry pi box running Ubuntu Mate as the desktop.   Works fine….

    Now when I reboot I cannot initially connect.  I get the 111 connection refused error.   I can ssh to the same RPI no problem.

    BUT….If now I wait for awhile magically the error goes away and I can connect.

    If I read the logs correctly it’s some error to do with IPV6.    I am connecting using the machine name not the ip address via avahi.  I wasn’t aware that the avahi daemon uses IPV6??   Could that be the issue.  It takes awhile before NoMachine can recognize the avahi machine name??  I use the machine name in my ssh connection hostname and I can ssh immediately to the box upon bootup so that indicates it’s a NoMachine issue as far as finding the hostname.

    I will try it with an ip address instead and report back if the error goes away.

    Info: Slave server running with pid 3117.
    Info: Listening to slave connections on port 33826.
    1824 1824 10:13:54 281.178 ClientSession: Stopped session at 0x281ce00.
    1824 1824 10:17:13 637.464 ClientSession: Starting session at 0x281ce00.
    1824 1824 10:17:13 637.791 ClientSession: Going to start session ‘/home/david/AllData/DGK/NoMachine/SBC – Ubuntu Mate – RPI – Base.nxs’.
    1824 1824 10:17:13 647.048 Connection: Finishing connection at 0x2c870f0.
    1824 1824 10:17:13 647.060 ClientDaemonConnector: Stopping the current connection.
    1824 1824 10:17:13 647.066 Connection: Finished connection at 0x2c870f0.
    1824 1824 10:17:13 647.069 Connection: Initializing connection at 0x2c870f0.
    1824 1824 10:17:13 647.111 Connection: Initialized connection at 0x2c870f0.
    1824 1824 10:17:13 647.119 Connection: Starting connection at 0x2c870f0.
    1824 1824 10:17:13 647.124 ClientDaemonConnector: Starting a new connection to host ‘sbc’ on port ‘4000’.
    1824 1824 10:17:13 647.191 Connection: Started connection at 0x2c870f0.
    1824 1824 10:17:13 650.573 ClientSession: Started session at 0x281ce00.
    1824 4398 10:17:13 732.261 Io/Io: WARNING! Can’t resolve IPv6 host ‘sbc’.
    1824 4398 10:17:13 732.290 Io/Io: WARNING! Error is 99, ‘Cannot assign requested address’.
    1824 1824 10:17:14 433.970 Connection: Connection at 0x2c870f0 failed.
    1824 1824 10:17:14 433.988 ClientSession: Runnable at 0x2c870f0 caused the session at 0x281ce00 to fail.
    1824 1824 10:17:14 433.995 ClientSession: Failing reason is ‘Could not connect to the server.

    Error is 111: Connection refused’.
    1824 1824 10:17:14 436.380 ClientSession: Stopping session at 0x281ce00.
    1824 1824 10:17:14 439.506 Connection: Stopping connection at 0x2c870f0.
    1824 1824 10:17:14 439.531 ClientDaemonConnector: Stopping the current connection.
    1824 1824 10:17:14 439.546 Connection: Stopped connection at 0x2c870f0.

     

     

    #14798
    Avatardkebler
    Participant

    No using the server’s ip address as opposed to it’s hostname does not resolve the issue.

    It takes about 4 minutes until the connection can be established…

    What would be causing this delay?

     

     

    #14799
    Avatarkroy
    Contributor

    NoMachine server processes need about 20 seconds for start on Raspberry Pi 3 with Ubuntu Mate 16.04. We couldn’t reproduce problem on the same environment (Ubuntu Mate 16.04, armv7, Raspberry Pi ver. 3, SD card class speed: 10).

    Can you send system (`/var/log/syslog`) and NoMachine logs to forum[at]nomachine[dot]com? Please enable debug, restart nxserver (`sudo /usr/NX/bin/nxserver –restart`) before you reproduce problem. Instructions about debug and collecting logs you can find there: https://www.nomachine.com/DT07M00098#1.

Viewing 3 posts - 1 through 3 (of 3 total)

Closed because the user did not provide further feedback. Please notify us if you confirm that it is resolved or open a new topic if you have the same problem.