Input issues between Win10 Client and Linux Mint server

Forums / NoMachine for Windows / Input issues between Win10 Client and Linux Mint server

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #40376
    Jethro_uk
    Participant

    Every so often something seems to “stick” in the connection, and trying to use the mouse scroll wheel results in Chrome changing it’s zoom. Also input seems to become as if the “CTRL” key is stuck on and you end up multi-line selecting. The only fix is to disconnect the session and reconnect. Everything is at the latest version.

    #40469
    Britgirl
    Participant

    Hi, We are aware of a similar behaviour that another user has reported, although we are not able to reproduce in our own environments. Please confirm the Linux Mint version and desktop environment (Mate, XFCE?).

    #40482
    Jethro_uk
    Participant

    System:    Kernel: 5.4.0-126-generic x86_64 bits: 64 compiler: gcc v: 9.4.0
    Desktop: Cinnamon 5.2.7 wm: muffin dm: GDM3 Distro: Linux Mint 20.3 Una
    base: Ubuntu 20.04 focal
    Machine:   Type: Laptop System: Hewlett-Packard product: HP ProBook 650 G1 v: A3009DD10303
    serial: <filter> Chassis: type: 10 serial: <filter>
    Mobo: Hewlett-Packard model: 1993 v: KBC Version 16.39 serial: <filter>
    BIOS: Hewlett-Packard v: L77 Ver. 01.20 date: 07/17/2014
    Battery:   ID-1: BAT0 charge: 46.4 Wh condition: 48.2/48.2 Wh (100%) volts: 12.3/10.8
    model: Hewlett-Packard Primary serial: <filter> status: Unknown
    CPU:       Topology: Dual Core model: Intel Core i3-4000M bits: 64 type: MT MCP arch: Haswell
    rev: 3 L2 cache: 3072 KiB
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19156
    Speed: 2395 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 2395 2: 2395 3: 2395
    4: 2395
    Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0416
    Display: x11 server: X.Org 1.20.13 driver: modesetting unloaded: fbdev,vesa
    resolution: 1366×768~60Hz
    OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 21.2.6
    compat-v: 3.0 direct render: Yes
    Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c
    Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20
    Sound Server: ALSA v: k5.4.0-126-generic
    Network:   Device-1: Intel Ethernet I217-V vendor: Hewlett-Packard driver: e1000e v: 3.2.6-k
    port: 3080 bus ID: 00:19.0 chip ID: 8086:153b
    IF: enp0s25 state: down mac: <filter>
    Device-2: Broadcom and subsidiaries BCM43228 802.11a/b/g/n driver: wl v: kernel
    port: ef80 bus ID: 02:00.0 chip ID: 14e4:4359
    IF: wlo1 state: up mac: <filter>
    Drives:    Local Storage: total: 223.57 GiB used: 222.05 GiB (99.3%)
    ID-1: /dev/sda model: SATA3 240GB SSD size: 223.57 GiB speed: 6.0 Gb/s serial: <filter>
    Partition: ID-1: / size: 216.82 GiB used: 110.44 GiB (50.9%) fs: ext4 dev: /dev/dm-1
    ID-2: /boot size: 702.1 MiB used: 215.8 MiB (30.7%) fs: ext4 dev: /dev/sda5
    ID-3: swap-1 size: 976.0 MiB used: 976.0 MiB (100.0%) fs: swap dev: /dev/dm-2
    USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002
    Hub: 1-1:2 info: Intel ports: 6 rev: 2.0 chip ID: 8087:8008
    Hub: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 chip ID: 1d6b:0002
    Hub: 2-1:2 info: Intel ports: 8 rev: 2.0 chip ID: 8087:8000
    Hub: 3-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 chip ID: 1d6b:0002
    Device-1: 3-5:2 info: Validity Sensors VFS495 Fingerprint Reader
    type: <vendor specific> driver: N/A rev: 1.1 chip ID: 138a:003f
    Device-2: 3-7:3 info: Chicony HP HD Webcam type: Video driver: uvcvideo rev: 2.0
    chip ID: 04f2:b3ed
    Device-3: 3-12:4 info: Broadcom HP Portable Bumble Bee type: <vendor specific>
    driver: btusb rev: 2.0 chip ID: 0a5c:21f1
    Hub: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 chip ID: 1d6b:0003
    Sensors:   System Temperatures: cpu: 49.0 C mobo: 0.0 C
    Fan Speeds (RPM): N/A
    Repos:     No active apt repos in: /etc/apt/sources.list
    Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http: //packages.linuxmint.com una main upstream import backport #id:linuxmint_main
    2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
    3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
    4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
    5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
    6: deb http: //archive.canonical.com/ubuntu/ focal partner
    Active apt repos in: /etc/apt/sources.list.d/signal-xenial.list
    1: deb [arch=amd64 signed-by=/usr/share/keyrings/signal-desktop-keyring.gpg] https: //updates.signal.org/desktop/apt xenial main
    Info:      Processes: 292 Uptime: 7d 2h 01m Memory: 3.75 GiB used: 2.60 GiB (69.2%) Init: systemd
    v: 245 runlevel: 5 Compilers: gcc: 9.4.0 alt: 9 Client: Unknown python3.8 client
    inxi: 3.0.38

    #42202
    Britgirl
    Participant

    Check your inbox from us 🙂 We’ve sent you a test package

    #42205
    Britgirl
    Participant

    Did you get a chance to test the package we sent?  🙂

    #42211
    Jethro_uk
    Participant

    I’m afraid I haven’t. But it’s still occurring from time to time. It’s definitely some process “stealing” the “ctrl+” input and not releasing it.

    Workaround is to close the NoMachine window (not session, for a clue) and reconnect. Since I have a workaround I can live with the bug. However YMMV.

    #42214
    Britgirl
    Participant

    The link we sent in the email to you to download is for a package that contains a patch. We were interested in knowing if it fixes the issue completely. If you get a chance to test it, please do 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.