Input language switch issues on remote machine

Forums / General Discussions / Input language switch issues on remote machine

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #31434
    Avatarwmoe
    Participant

    Hi,

    I’m experiencing issues with multiple input languages. When I connect to a remote Ubuntu (Xfce) PC NoMachine picks up only English or German depending on which language I had set before making a connection. I tried to use other Ubuntu PC and Windows 10 PC – the same issue there. I can use the only language that was chosen before the connection to the remote PC. While I’m connected NoMachine completely ignores that I change the input language on my PC and this change doesn’t make any difference on the remote PC. I want to be able to change input language using regular hotkeys in Windows/Ubuntu as it happens in [removed]/[removed]. Is there any workaround?

    #31463
    Avatarwmoe
    Participant

    Just for reference, I’m using Ubuntu 20.04.1 LTS and Windows 10 October edition with latest updates installed and latest available NoMachine both on the client and remote PCs.

    #31488
    Avatargraywolf
    Moderator

    While I’m connected NoMachine completely ignores that I change the input language on my PC and this change doesn’t make any difference on the remote PC.

    Hello. It is exactly the expected behavior. Client and remote session can get different keyboard layouts. In order to change the keyboard layout in a remote Xfce (or Gnome, or KDE) session, define multiple layout in the Xfce System Settings: then you’ll be able to switch layouts by just clicking on the Keyboard layout applet in the Xfce panel or using the Xfce hotkey bonded to action “switch layout”.

    #31522
    Avatarwmoe
    Participant

    Alright, I added German layout to the remote PC and set hotkey there to change layout be win+space. When I connect through NoMachine to remote PC from Windows 10 I can’t switch keyboard layout – it switches in Windows only and NoMachine doesn’t pick it up. The hotkey works perfectly fine on remote PC if I physically use the kb there or connect over other remote control software. Could you please advice how can it be fixed?

    #31550
    Avatargraywolf
    Moderator

    Win+Space is caught by Windows so it is not passed through the client and does not get to the remote session. I’d suggest to bind a different hotkey to the switch layout action in the remote desktop. Otherwise, turn on NoMachine client setting “Grab the keyboard input”.

    #31642
    Avatarwmoe
    Participant

    It works, thank you.

Viewing 6 posts - 1 through 6 (of 6 total)

This topic was marked as solved, you can't post.